Upgrade disaster....

Discussion in 'Droid X Tech Support' started by SMMAssociates, Sep 20, 2011.

  1. SMMAssociates

    SMMAssociates New Member

    Sep 23, 2010
    Likes Received:
    Trophy Points:
    (Well, almost.)

    The phone (Droid X, if you haven't guessed by now :D) told me that there was an OS upgrade available, and I agreed.

    A message to the effect of "wait about five minutes" popped up. Put the phone down (lots of battery :)) and went and did something else.

    Came back some ten minutes later, and it's alternating between the "DROID" words and the "eye" thing. No buttons do anything.... Yanked the battery, and tapped the power button after putting it back. Red "M" logo, and then back to the loop....

    Hit the Motorola site for some info on how to do a Ctrl-Alt-Delete sort of thing, and found the method for the upgraded version of the OS (obviously there'd been a flash upgrade of some kind to change that, which leads to a "why the heck did they change that?", but that's another thread). Eventually I'm back at "factory" for the new release....

    Whole different world :D, but nothing impenetrable. I had everything of consequence backed up (Missing Sync and Outlook), so remembering which ring tones I'd used, and adding back some apps wasn't a big deal. (This is the second time I've had to suicide the thing - first time the OS just got stupid - forgot it had a "Home" button, for example.)

    Comes the problems:

    1. Fox News no longer lets me scroll horizontally between stories. If I tap the second story of a group, I have to "back" to the main Fox screen and tap the next one I want to see. I used to be able to scroll with right and left "swipes". (This could be a keyboard option I haven't found yet.)

    2. The "default" browser, which kinda drove me nuts, but I got used to it to the point of avoiding a couple of others, now insists on going back to the top of a page if I "home" out of it, and then start the browser again. (IOW, jump out to check some other app, for example, and try to go back to where I was on the browser page.) The prior version used to go stupid and forget what "windows" I'd set up were pointed to, but this seems to be consistent. Guess it's time to give up on that....

    Otherwise, some screen icons were changed - apparently for somebody's "good reason", but.... I couldn't find "Market" or even that "show me the apps" screen, for a while.

    In the "total lunacy" department, the phone forgot all my contacts, as expected, except for a very few (like six out of about 400). No problem reloading that stuff, but really strange.

    Utterly unrelated, but can anybody give me a simple "how to get Java working in a browser"? I really need it, but so far nothing has worked. Probably because I had/have no idea what I'm doing....

    Can't really complain. Other than a re-boot every once in a while (fully power down), it's been decent, mostly. It seems like the guys who designed my previous phone (Samsung Omnia, which I really liked, and supported Java, too :)) never actually tried to use it. Very inconsistent interfaces.... Better in that respect, but I don't know what I'll do next year at "re-up" time....

    BTW, battery life has been fine, but every once in a while the thing just draws itself down all the way. No idea what it's doing on my belt when that happens.