Update Security Settings

Discussion in 'Android Tech Support' started by jwendler, Sep 13, 2010.

  1. jwendler

    jwendler New Member

    Joined:
    Sep 13, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ever since taking the 2.2 update, Exchange (on the phone) has been saying "Update Security Settings" for my corporate account.

    So i click that, it takes me to my account settings. In my incoming settings, i verify the information, click next... then i get this message:

    Remote Security Administration: The server <my server> requires that you allow it to remotely control some security features of your phone. Do you wish to finish setting up this account?

    I hit ok, and it takes me back to my account settings. And that’s where I’m lost...

    Any ideas?
     
  2. joeydvdz

    joeydvdz New Member

    Joined:
    Aug 18, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ditto. Help! Doesn't seem to hurt anything, but it is annoying.
     
  3. droidn

    droidn New Member

    Joined:
    Dec 7, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have this problem too. Anyone figure it out yet? Is this a bug in Froyo?
     
  4. dlwhtrose

    dlwhtrose DF Super Moderator Rescue Squad Premium Member

    Joined:
    Dec 10, 2009
    Messages:
    2,795
    Likes Received:
    3
    Trophy Points:
    103
    Location:
    God forsaken desert, wishing to be back in Dixie
    Ratings:
    +3
    You may have to check with your Exchange IT person to find out what the security settings should be. I had to do that in order to get my work email to start coming to my phone.
     
  5. dmerrick

    dmerrick New Member

    Joined:
    Sep 23, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Anyone figure out how to stop this below???

    Ever since taking the 2.2 update, Exchange (on the phone) has been saying "Update Security Settings" for my corporate account.
     
  6. Tallica

    Tallica Premium Member Rescue Squad Premium Member

    Joined:
    Mar 17, 2010
    Messages:
    3,259
    Likes Received:
    1
    Trophy Points:
    101
    Location:
    Middleboro, MA
    Ratings:
    +1
    So...did you read this thread at all before posting? dlwhtrose answered it in the post right above yours.
     
  7. OldFatGuy

    OldFatGuy New Member

    Joined:
    Sep 28, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    That doesn't answer anything really. It says: You may have to check with your Exchange IT person to find out what the security settings should be. I had to do that in order to get my work email to start coming to my phone.

    I am getting email and I checked with my Exchange Admin and all is well as far as they are concerned. I get email all day long - it's just that I also get this annoying pop-up every time I power on the phone or email gets restarted.

    Does anyone have a real answer, like what needs to be checked or changed or whatever the case may be?
     
  8. Droids

    Droids Member

    Joined:
    Nov 23, 2009
    Messages:
    793
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I get the same prompt anytime I reboot the phone. I just have to verify the settings and click ok to it. Only occurs after a reboot which is rare. It's annoying and I consider it a bug since there is no actual security change needed. Haven't found a fix so I live with it, for now.
     
  9. BigDaddyNYY

    BigDaddyNYY Member

    Joined:
    Jul 30, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    PA
    Ratings:
    +0
    I just helped a co-worker with this issue yesterday, at least I was able to get it to work yesterday (haven't checked with her yet today). What I did was make sure that there was a check mark in both of the security options, I think one was to use SSL and the other was to accept certificates (again, I believe these were the options, but I selected both). After doing that, I choose to continue and it verified the account, but the error message popped up in the notification bar again. I then went back into the exchange setup, verified the account settings, didn't change anything just continued with the process and everything started to work.

    If this is of no help, I can try to get her phone when I get out of the meeting I am about to go to, and see if I missed something. Good Luck
     
  10. emeacham

    emeacham New Member

    Joined:
    Oct 12, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iowa
    Ratings:
    +0
    -- POSSIBLE FIX --

    I had the same issue many of you have stated above on my Droid (Milestone). I resolved it by doing the following...

    Applications > Email
    Press and hold on the affected account and choose "Remove account" then press OK.

    Once that is done, setup your account again.
     
  11. jaytime

    jaytime New Member

    Joined:
    Aug 21, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I get this nag notification often. However, I am aware what IT policy I don't have in place. In my case, it is the need for an unlock password on my phone... which I don't want. I know why I should have it, but I don't want it. Please save your breath lecturing me about security.

    @OldFatGuy: you need to ask about your IT admin about the specific security policy, not just for your mail server settings.

    I've removed and added the account several times, but this doesn't stop the message. It doesn't just appear when I startup, it appears every time a new email arrives. Ugh!
    In my case, when I click on the notification, it doesn't even take me to the account settings or phone settings. It doesn't know what to do, so it just goes away. I would still prefer not to be nagged about it all the time.

    The workaround for me was to disable email push. I set it to never check--I'll do it manually when I need to check this email remotely.

    I suspect many of you will need or want push notifications enabled and I think you're out of luck besides obtaining the correct security settings and implementing them on your phone. Consider yourself lucky that it synchronizes at all without the correct security settings. When Google gets around to making Exchange a priority, you likely won't be able to sync OR your Exchange admin will be able to control many aspects of your phone, including a remote wipe if they so choose.

    My ideal (which is probably a couple years away before programmers get around to setting it up this way), would be to require the security policy for the ACCOUNT (managed by the app, but I would accept for the whole APP too since most people don't have Exchange accounts from different orgs), but not for the whole phone. So, if my Admin wants a two factor authentication, then the app can require a password before displaying my email.
     
  12. FWSoccerDad

    FWSoccerDad New Member

    Joined:
    Oct 23, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Obviously, you weren't an English major and don't read much. What you claim is an answer is anything but a definitive answer. You ought to save your sarcasm for topics you know something about because you only expose yourself when you pop off and are wrong.
     
  13. FWSoccerDad

    FWSoccerDad New Member

    Joined:
    Oct 23, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I removed my account and set it up again last week. Unfortunately, it didn't solve my problem. I still get the "update security settings" message each morning and sometimes during the day.
     
  14. akuma6099

    akuma6099 New Member

    Joined:
    Oct 23, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Me too

    I have just ran into this over the weekend. I moved to another ROM on friday. I was using corporate sync but now I'm forced to use Exchange option instead. I've noticed a few things. First, the email account needs to be listed as a device administrator in the Location&Security->Device Admins. This lets the "E-Mail" application control certain features from the exchange side. This includes a remote data wipe of Email data only. Force a pin code policy for the phone due to potential security risk of lost phone. Log logins. maybe a few others. It doesn't include My Location, uninstallation of apps..... Anyways Second, my company uses a self signed certificate which would require user intervention using any web browser. The cert wasn't signed by a licensed vendor like verisign. It was signed by our internal exchange server so it asks you to verify it. This requires you to check the option "Accept All SSL Certificates" under Account Settings->Incoming Options. Finally I noticed it asks to "Update Security Policy" on every reboot. I also had my Wifi on and the router was clogged and non-responsive. Wouldn't issue DHCP. The E-mail app couldn't sync correctly as the icon swirlled in circles. Turned on 3G, went into Account Settings->Incoming Options and tapped Next. It popped up a box asking to add xxx.yyy.com as an admin, I said OK. Go back to your inbox and let it re-sync. Reboot. Still get the error.

    I have setup a pin, deleted the account, wiped the "EMail" application settings, create account, apply admin approval, resync, and reboot. The error persists. At this point its pointing to default behavior of the EMail program. If you reboot your phone and quickly open up Email and goto your inbox, it should say "Unable to open...security error" near the top within a minute. You get 2 notifications one after the other. If you hit menu->refresh a couple times, the "Unable to open..." message goes away. Maybe Email is waiting on an event that isn't triggered for a bit.... Or it takes just a minute or two after booting to get the 3G setup and functioning. Not quite sure. let me know if you find a workaround.
     
  15. Droids

    Droids Member

    Joined:
    Nov 23, 2009
    Messages:
    793
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
Search tags for this page

account requires security settings update

,
android email account requires security settings update
,
android update security settings to use account
,
null requires that you update your security settings
,
requires security settings update
,
server must be able to remotely control
,
update security setting
,
update security settings
,
update security settings android
,

update security settings to use account