Unsuccessful installation bug?

Discussion in 'Android General Discussions' started by meepstone, Jan 22, 2011.

  1. meepstone

    meepstone Member

    Joined:
    Jan 28, 2010
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Discussed this a week ago on the forum here and no one knew an answer to fix it.

    Problem: Certain apps always say unsuccessfull installation, for no apparent reason while others install fine.

    I came across a minor fix from googling. If I unmount the SD card and go and download/install the app from the market it will install no problems. Then I just re-mount the sd card. But it still does not update the app. It will say update unsuccessful.

    Very curious problem that is slightly annoying. Anyone that's smart can chime in here, cus I'm baffled.
     
  2. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    1. Is your phone rooted?
    2. Are you running a custom rom?
    3. Do you have any apps on the SDcard?
    4. Have you tried a factory hard reset?
     
  3. meepstone

    meepstone Member

    Joined:
    Jan 28, 2010
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    1. Yes
    2. BB 6.2.1, First had the problem on CM 6.1.2
    3. Yes
    4. No, I did a data/cache wipe when switching from CM to BB in hopes to resolve the problem. But when I did it. I still had like 6 apps not install.
     
  4. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    Somewhere in the BB settings, there is an option as to where to install apps that are downloaded. You probably have that set to sdcard or automatic. Try setting it to internal only.
     
  5. les017

    les017 Member

    Joined:
    Nov 13, 2009
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    The times I have seen this are after flashing a different rom. Rarely have I been able to uninstall the app and install fresh. Normally I use the search feature in Root Explorer to find ALL files that contain a select key word and then erradicate appropriately.

    Last example was google earth would not reinstall after flashing PE4. 2,not even via Titanium. So I searched on"earth " and you wouldn't believe all of the files that were found, scattered all over. Deleted one by one and a fresh installation went fine
     
  6. parker34

    parker34 Member

    Joined:
    May 31, 2010
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Al
    Ratings:
    +0
    I had this problem a while back and if i'm not mistaken, someone told me to delete the contents in android.secure (which i believe is where the applications are installed on your sd card)....you will have to reinstall all your apps that were on your card though...I did this and haven't had it happen since, **knock on wood**
     
  7. meepstone

    meepstone Member

    Joined:
    Jan 28, 2010
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks for the responses. I'll try them soon, at work so I can't try this right away.
     
  8. meepstone

    meepstone Member

    Joined:
    Jan 28, 2010
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    In BB, there is not a setting in the rom toolkit about forcing Apps to install on the sd card. Using root explorer to delete every instance of an app didn't work and deleting android.secure I didn't bother cus the apps aren't installing to the internal card. Only a select few do this.

    Sent from my Droid using DroidForums App