Typing lag

Discussion in 'Droid Moto Z Force' started by jkaod, Jan 31, 2017.

  1. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    I've noticed over the past few weeks a big lag when I'm typing text. It's kind of intermittent. If I start typing a text and there is lag, if I close it and them come back to the draft of the text, reopen it and start typing again, there is no lag at all. Anyone else notice this and does anyone have any suggestions? It's become a real pain.
     
  2. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,646
    Likes Received:
    6,751
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,254
    Current Phone Model:
    Moto Droid Z Force
    Are you using the stock Google Keyboard, or an alternative one from the Play Store? If the stock one, is the app up to date? There was an update a week or so ago? The only time I have noticed lag is when using Hangouts, so I assumed that was an app specific lag. Haven't noticed it anywhere else...Yet.

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1
  3. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    I have tried it with different keyboards and get the same thing with all of them....Google keyboard, TouchPal, AI type keyboard. Tried clearing cache on the apps, updating the apps, clearing partition cache, even did the dreaded FDR all with no help. I've tried it with various messaging apps as well.
     
  4. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,646
    Likes Received:
    6,751
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,254
    Current Phone Model:
    Moto Droid Z Force
    Most of these newer keyboards seem to have a constant data connection. How is your signal strength?

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1
  5. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    Excellent. I happens when I'm on 4G or wifi, no difference.
     
  6. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    Have you tried clearing your data on your stock keyboard? Might sound strange since it happens on more than stock but...

    Support Our Troops!!!
    Beast Mode 4

    <><
     
    • Like Like x 1
  7. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    I've tried clearing data and cache on everything including my brain...not much to clear there. I wonder if it's a bad combo of keyboards and message apps. I've alternated between Message+ and Textra for messaging apps and stock google keyboard, TouchPal keyboard, and AI keyboard. There are so many combinations, I'm not sure if I tried them all. I just now went back to stock everything and uninstalled all of the other ones to see if there was some conflict. I'll see how it goes. Thanks.
     
    • Like Like x 1
  8. xeene

    xeene Gold Member

    Joined:
    Jun 28, 2010
    Messages:
    3,067
    Likes Received:
    893
    Trophy Points:
    208
    Location:
    usa
    Ratings:
    +1,029
    Do you have vibration enabled when pressing a key? How about any form filling app like 1password? Any word predictions enabled? I would try fdr without installing any apps to rule out phone hardware.
     
  9. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    No vibration enabled, word prediction is enabled, no form filling apps. It's so sporadic is what makes it hard to nail down. I can text 20 times and it's perfect and then the next time it lags big time. Thanks for all of the advice.
     
  10. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    Do you have Swype keyboard installed? Using it or not. If so try uninstall it and run without it for a few days.
    Also have you tried running your phone in safe mode to see if it's an aftermarket app or not?

    Support Our Troops!!!
    Beast Mode 4

    <><
     
  11. jkaod

    jkaod Gold Member

    Joined:
    Feb 3, 2010
    Messages:
    756
    Likes Received:
    364
    Trophy Points:
    203
    Ratings:
    +416
    I don't have Swype installed. I had a couple of other keyboards installed and I recently uninstalled them all except for the stock google keyboard to see if there was some conflict with them. So far it seems to be OK, but time will tell.
     
    • Like Like x 2