1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Turning on Wireless kills all data connections

Discussion in 'Motorola Droid X' started by edgekrusher187, Aug 6, 2010.

  1. edgekrusher187
    Offline

    edgekrusher187 New Member

    Joined:
    Aug 6, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Anyone else have this issue. When I turn on the wireless any attempts to get anywhere internet related fails to work. I stop receiving corporate emails. I am getting a connection to the AP, and getting an IP address but nothing works until I turn wireless off, then I can get to what I want using 3G and Corporate and gmail emails start to flow. Any insight would be helpful.

    Thanks
  2. Humpa
    Offline

    Humpa New Member

    Joined:
    Jan 3, 2010
    Messages:
    440
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas
    Once you turn on wifi and connect to an wifi hotspot/router, then your data will use that instead of 3G/1X. Sounds like something is wrong with whatever you are connecting to - is it using a proxy or something?
  3. nfj79
    Offline

    nfj79 New Member

    Joined:
    Jul 29, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    I have the same problem with my DX. Wireless is on and connected to my home wireless network. My DX shows I have a wireless signal and the 3G symbol is gone. I'm using my default Droid browser. I can surf for awhile, then it'll just stop working. Click refresh and nada.
  4. Humpa
    Offline

    Humpa New Member

    Joined:
    Jan 3, 2010
    Messages:
    440
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas
    Try turning off that "sleep" mode setting in your wifi settings on the X.

    I'd turn off the battery manager stuff too, and set it to performance. But I think turning off the "sleep" thing might fix the issue.
  5. nfj79
    Offline

    nfj79 New Member

    Joined:
    Jul 29, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    I dont see a "sleep" mode in wifi settings. Why would it go into sleep mode if you're on the browser surfing away?
  6. edgekrusher187
    Offline

    edgekrusher187 New Member

    Joined:
    Aug 6, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Not using any kind of proxy. Connecting directly to the AP at work, and have the same issues when I'm at home.
  7. Humpa
    Offline

    Humpa New Member

    Joined:
    Jan 3, 2010
    Messages:
    440
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas
    It shouldn't. But if that new "sleep" setting is buggy, then I'm thinking it could be the problem.

    Any time there is an issue, I go into troubleshooting mode (as should anyone). And that means trying to determine the problem. This was just the simplest "step 1" to try.

    You cannot find the wifi sleep settings? It is right in the wifi settings. It is called Wi-Fi sleep policy. Set it to "never" - it sure couldn't hurt to try changing that, was my point.
  8. edgekrusher187
    Offline

    edgekrusher187 New Member

    Joined:
    Aug 6, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0

    I found it. Once you are in Wi-Fi settings clicking the options button, left physical button, you will see an option for "Advanced". In the Advanced menu you'll see the Wi-Fi sleep policy. Once I had set that to Never it started working for everything but corporate email. Since I need to get those emails, I'll just stick with the 3G until a fix is found.

    Thanks Humpa! :rockon:
  9. Humpa
    Offline

    Humpa New Member

    Joined:
    Jan 3, 2010
    Messages:
    440
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas
    And for the newbies, every app has settings. With Android, you need to get used to the Menu button. There's always something in there. And if one of the things says "More" or "Advanced", you need to click it and see what's there. And different screens sometimes have a different "Menu".
  10. nfj79
    Offline

    nfj79 New Member

    Joined:
    Jul 29, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Found it! Thanks!

    I also read that the X has a known problem connecting to some wireless routers. I'll have to play around with some settings.
  11. jswinberlin
    Offline

    jswinberlin New Member

    Joined:
    Aug 27, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    No Wireless Connectivity in the office

    I sync with my office Exchange server. This incorporates the external IP Address. You cannot connect to this address from inside the office. For example if the external is 177.10.236.88, inside the LAN there is no need to go here so the DNS server doesn't really know what you're talking aobut. You would go to the class C address of something like 192.168.0.1 inside the LAN. However, doing this would require you to put in one IP address inside the LAN and one when you're outside.

    It's much more simple to just use the external and use the 3G connecitivy. Is there some reason why you need to connect to the LAN?
Search tags for this page

android phone killing wifi router connection

,
wifi hotspot kills data connection