Turning off "Call From" voice in incoming call

Discussion in 'Samsung Galaxy S3' started by akshay_91989, Jun 3, 2013.

  1. akshay_91989

    akshay_91989 New Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pune, India
    Ratings:
    +0
    Every time I get an incoming call, before my ringtone, there's an electronic voice that says "Call From" so-and so. Is there a way to turn this off?
    Even after receiving call, it doesn't stop. Please help me to get rid of this so called feature. :(
     
    #1 akshay_91989, Jun 3, 2013
    Last edited: Jun 3, 2013
  2. scott32746

    scott32746 Member

    Joined:
    Jan 31, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    There are apps like Robin, Whoisit and other Assistant type apps. Need to check them if you have one of them
     
  3. Roget83

    Roget83 Member

    Joined:
    Jul 19, 2012
    Messages:
    50
    Likes Received:
    4
    Trophy Points:
    8
    Ratings:
    +4
    Make sure not in driving mode. That will cause your phone to read incoming calls and texts.
     
  4. akshay_91989

    akshay_91989 New Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pune, India
    Ratings:
    +0
    Thanks! But i have tried doing that as well.

    But issue still persists with my handset. Is there some other way to resolve this problem :(
     
  5. akshay_91989

    akshay_91989 New Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pune, India
    Ratings:
    +0
    Hey scott32746, Thanks for reply! I have checked my installed apps,even checked for similar kind of apps but none of them matches with the list you have provided.
     
  6. akshay_91989

    akshay_91989 New Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pune, India
    Ratings:
    +0
    I've got a strange problem -- sometimes, but not everytime - when I receive a call (depends on ther person and number they're using) the call is being announced with voice output, as the phone rings.

    When I accept the call, that voice keeps speaking, right INTO the start of the conversation. And the other party can hear it talking.

    This just happened:

    Phone rings for 2 seconds.
    3rd second, I accept the call, seeing it's my buddy on the line.
    4th second, I just want to say hello, but I am interrupted with this thing screaming in my ear "INCOMING CALL FROM ...".

    How do I turn this damn thing off? Once and for all? Driving mode is disabled. I triple checked.
    Please help me!
     
  7. andiguy

    andiguy New Member

    Joined:
    Dec 4, 2012
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Have you enabled any 'Talkback' feature in Accessibility settings?
     
  8. akshay_91989

    akshay_91989 New Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pune, India
    Ratings:
    +0
    Thanks! Talkback option is already off!
     
  9. scrufff

    scrufff New Member

    Joined:
    Jul 15, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    i had the same problem....
    go into Accessibility, click on "Talkback" even if it is turned "off"
    unclick "Speak Caller ID"
    it worked for me.
     
  10. scbyrdy

    scbyrdy New Member

    Joined:
    Jan 26, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks, I just turned off "Driving Mode" & my voices stopped!! Thank you so much!
     
Search tags for this page
how to remove voice from incoming call
,
how to turn off call announcement on samsung galaxy s3
,
how to turn off incoming call voice
,
how to turn off incoming call voice on galaxy s3
,

how to turn off incoming call voice on samsung galaxy s3

,

how to turn off voice on incoming calls

,

incoming call voice

,
incoming call voice announcement
,
samsung incoming call voice
,
turn off call announcement android