[THEME] SS Evolution

Discussion in 'ChevyNo1' started by Benny879, Aug 22, 2010.

  1. wesblake

    wesblake New Member

    Joined:
    Jul 12, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm still really confused as to how you all could be using the 4.8 version on 4.9 with no issues. I thought it was originally the settings.apk file that had to be replaced in the 4.7 version to make it 4.8 compatible, and this time chevyno1 must have made tweaks again to settings.apk because his settings are no longer in there, they are in their own app.
    Are you all SURE that the 4.8 from Rabbitfoot is fully compatible with 4.9? I already went to 4.9 because I couldn't wait, but I'm REALLY missing the evolution theme. By far the best theme I've used to date!
     
  2. xeooex

    xeooex New Member

    Joined:
    Jun 21, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Maybe Chevy can clarify if the 4.8 evo theme will work? I really appreciate the hard work everyone does to make the OG droid still the best phone i have ever owned.
     
  3. y0rk

    y0rk Member

    Joined:
    Feb 20, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    These are the possible issues that will arise when applying the 4.8 theme onto 4.9:

    The older version of Settings.apk has the older version of ChevyTools built in. He has removed his code from the system app and created his own app. Applying the old theme can leave you with two versions of ChevyTools. One definitely won't work correctly because it's expecting a different services.jar. No idea if the standalone version will still function with the extra one there.

    4.9 is built off the 2.2.1 framework and includes 2.2.1 versions of the system apps. There probably aren't a lot of updates between 2.2 and 2.2.1 for things like the calculator, but this is what's causing the FC's in Gmail. 4.9 installs the newest one and then the theme installs an older one.

    Not sure if the theme has a copy of services.jar in it, but if it does you definitely don't want to install the older one into 4.9.

    Hope that helps clarify a few things for you guys.
     
  4. xeooex

    xeooex New Member

    Joined:
    Jun 21, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yeah makes sense for sure, any chance it will be ported to 4.9?
     
  5. Mattpfeil

    Mattpfeil Member

    Joined:
    Mar 31, 2010
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Go back a few pages and you will find this theme for 4.8. Rabbitfoot posted it.

    It will work, you just have to update gmail from the market or it will fc on you.

    Then go to the bugless beast thread and find the bugless evolution thread. The themed launcher pro is in there.

    Sent from my Droid using DroidForums App
     
  6. wesblake

    wesblake New Member

    Joined:
    Jul 12, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Sorry, go back a couple posts, I mentioned and York confirmed this is not a 100% solution. settings.apk has changed again as chevy moved his tools from the settings menu. York, all Rabbitfoot did to make a 4.8 from 4.7 was replace settings.apk in the theme with the 4.8 version if I understand correctly. Wouldn't this be a sufficient method then to also create a 4.9 version?
     
  7. y0rk

    y0rk Member

    Joined:
    Feb 20, 2010
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    should be. just make sure there isn't an old copy of the services.jar in the theme as well. if you apply the settings.apk and services.jar from 4.8 or 4.7 you are basically reflashing that version of the rom no matter what the build.prop says.
     
  8. rabbitfoot

    rabbitfoot Member

    Joined:
    Jan 21, 2010
    Messages:
    407
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    nYc
    Ratings:
    +2
    something to keep in mind: all APKs that are in this theme will overwrite the SS4.9 ones. the previous APKs were the most current up until that point, just as the SS 4.9 ones currently are. i'm not sure which ones have been updated since but many you can update in the market, like gmail, youtube, twitter, and facebook.

    also, i just checked the theme, the only change to /system/framework/ is the framework-res.apk so you're safe with the services.jar.

    best,
    rf
     
    #188 rabbitfoot, Nov 9, 2010
    Last edited: Nov 9, 2010
  9. 9wire

    9wire Member

    Joined:
    Sep 27, 2010
    Messages:
    333
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I used Rabbitfoots 4.8 and have Chevy tools as it's own app and in the settings menu. Did the market update fix on gmail, been using it several days now and no problems yet.
     
  10. wesblake

    wesblake New Member

    Joined:
    Jul 12, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    That's just it, that means it's broken. Chevy Tools should not still be in the settings menu in 4.9
    I don't know enough to port this, does someone know how to make a proper 4.9 version? I'm holding onto 4.8 for now, can't go without this theme! :)
     
  11. rabbitfoot

    rabbitfoot Member

    Joined:
    Jan 21, 2010
    Messages:
    407
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    nYc
    Ratings:
    +2
    none of the work is mine. all the credit goes to benny for porting, manup for theme, and chevy for his rom. i take zero credit for what i'm posting and expect just as much of the blame :) so make a backup first! remember, i'm just some dode on the internet.

    for those of you who flashed the 4.8 update, maybe you'll find this helpful: all i did was throw in the framework-res.apk from 4.7/4.8 which many of you reported works perfectly fine with 4.9. i've also taken the .png files from 4.7/4.8 settings.apk and threw them in the notheme 4.9 settings.apk.

    again, expect this not to work so BACKUP FIRST!

    good luck

    best,
    rf
     
  12. wesblake

    wesblake New Member

    Joined:
    Jul 12, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks!

    Thanks rabbitfoot! So I know just enough about themes to break stuff. Let me see If I'm figuring this right, would you just install the 4.8 port you made, then install this "settings&frame..." file you just posted after and it's effectively a 4.9 theme?
     
Search tags for this page
agenda tema sslauncher zip
,
ss launcher theme zip
,
sslauncher theme collection
,

sslauncher theme zip

,

sslauncher themes zip

,
sslauncher zip
,
sslauncherzip
,
tema ss launcher zip
,
tema sslauncher zip
,
zip theme for sslauncher