Swype replacement issue

Discussion in 'Droid X Hacks' started by joshoid, Sep 22, 2011.

  1. joshoid
    Offline

    joshoid New Member

    Joined:
    Dec 10, 2010
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Ohio
    Rooted X .602

    Without much thought I removed system file swype.apk from data/app using System app remover. I then installed swype installer and installed swype 3.0. Everything worked well until I rebooted my phone. Upon reboot I get com.swype FC repeatedly and cannot get it running. If I must I believe I can go to system dump and manually push swype.apk back into data/app but the swype available from their WP is much more advanced and I would rather use that.

    What are my options?

    Thanks!
  2. Snow02
    Offline

    Snow02 New Member

    Joined:
    Jan 12, 2011
    Messages:
    1,342
    Likes Received:
    9
    Trophy Points:
    0
    Just uninstall the beta, then reinstall. That will fix it.

    Also, make sure you rename/remove the libswypecore.so file from /system/lib.
  3. joshoid
    Offline

    joshoid New Member

    Joined:
    Dec 10, 2010
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Ohio
    Working great thanks! Just from a learning stand point what does sys/lib function.

    Sent from my DROIDX using Tapatalk
  4. AngelOfAnger
    Offline

    AngelOfAnger New Member

    Joined:
    Oct 2, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    I think that file is a library associated with SWYPE. Something may have gotten corrupted the first time you downloaded it. Deleting the aforementioned file will just make sure that you're starting over with a legitimate clean slate. :)
Search tags for this page

swype issues replacement