Stuck in bootloop after bad recovery flash. Fastboot commands hanging. Please help.

Discussion in 'Android Hacks and Help' started by JesseB342, Feb 12, 2017.

  1. JesseB342

    JesseB342 New Member

    Joined:
    Feb 12, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Coolpad Quattro II 4G
    I attempted to flash TWRP to my phone (Coolpad 801es). Since there's not an official version for my phone, I watched a Youtube video explaining how to take an official TWRP and port it to your phone using Android kitchen. The video said as long as the screen resolution of the two phones matched, it would work. I followed the video and then used Flashify to back up my stock recovery and kernel before flashing the ported TWRP. The flashing was successful, but upon reboot I am now in a bootloop. I tried to test the port through Fastboot before flashing, but "Fastboot reboot recovery.img" just caused it to hang at "waiting for device" and "Fastboot devices" just returned a blank line. Standard ADB commands won't work since the phone doesn't actually get that far in the loop. I tried "ADB wait-for-device" but with no luck. I knew I should have tested it before flashing, but I was impatient and now i'm paying for it.

    Anyway, after further research I discovered that I could get Fastboot to work by adding "-i 0x1ebf" before a command. so typing "Fastboot -i 0x1ebf devices" returns my device info instead of a blank line. Since I know the correct drivers are installed (device manager shows Android ADB interface under Android phone when I plug it in) and I can get into Fastboot mode since the procedure for this phone is to plug it in without the battery installed, thus the bootloop isn't an issue. Also, the screen says "Fastboot mode" on it.

    I thought I was in the clear being able to access Fastboot and issue commands. I tried "Fastboot -i 0x1ebf flash recovery recovery.img" (thank God I thought to copy my stock recovery to my PC at least) which should fix it. Trying that command, I get "sending 'recovery' <10240kb>. . ." and then nothing. I've waited for an hour at this step which should be more than enough time for it to complete and still nothing. I've also tried every USB port on my PC (front and back) and two different cables. This should be working but it's not.

    Sorry to be so wordy, i'm just trying to include all pertinent details. I did ask over at XDA but I guess they're all too busy to help. Not a single reply. At this point i'm out of ideas. Can anyone help me?