Strange problem with Eclipse and Win 7

Discussion in 'Android Hacks and Help' started by Roseman, Aug 30, 2011.

  1. Roseman
    Offline

    Roseman New Member

    Joined:
    Aug 30, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I'm just starting out with Android development and I'm following the Dummies guide - one has to start somewhere! running Eclipse on and XP machine it works perfectly. Running exactly the same scenario on my Windows 7 laptop (much faster and larger screen) the emulator launched but the application doesn't. I've re-installed everything and attempted to trace any slight difference in the configurations but can't see anything. It must be something simple. These are the console outputs for the respective Eclipse installations:

    __________________________________________________ _________

    Windows XP - Emulator launches and so does the application.


    [2011-08-29 12:51:16 - IAmAYak] ------------------------------
    [2011-08-29 12:51:16 - IAmAYak] Android Launch!
    [2011-08-29 12:51:16 - IAmAYak] adb is running normally.
    [2011-08-29 12:51:16 - IAmAYak] Performing com.dummies.android.MainActivity activity launch
    [2011-08-29 12:51:16 - IAmAYak] Automatic Target Mode: Preferred AVD '2_2_Default_HVGA_NoSD' is not available. Launching new emulator.
    [2011-08-29 12:51:16 - IAmAYak] Launching a new emulator with Virtual Device '2_2_Default_HVGA_NoSD'
    [2011-08-29 12:51:19 - Emulator] emulator: emulator window was out of view and was recentred
    [2011-08-29 12:51:19 - Emulator]
    [2011-08-29 12:51:19 - IAmAYak] New emulator found: emulator-5554
    [2011-08-29 12:51:19 - IAmAYak] Waiting for HOME ('android.process.acore') to be launched...
    [2011-08-29 12:51:54 - IAmAYak] HOME is up on device 'emulator-5554'
    [2011-08-29 12:51:54 - IAmAYak] Uploading IAmAYak.apk onto device 'emulator-5554'
    [2011-08-29 12:51:54 - IAmAYak] Installing IAmAYak.apk...
    [2011-08-29 12:52:28 - IAmAYak] Success!
    [2011-08-29 12:52:28 - IAmAYak] Starting activity com.dummies.android.MainActivity on device emulator-5554
    [2011-08-29 12:52:32 - IAmAYak] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.dummies.android/.MainActivity }


    __________________________________________________ _________

    Windows 7 - Same project conditions but different result. Emulator launches but not the application.

    [2011-08-29 12:44:53 - IAmAYak] ------------------------------
    [2011-08-29 12:44:53 - IAmAYak] Android Launch!
    [2011-08-29 12:44:53 - IAmAYak] adb is running normally.
    [2011-08-29 12:44:53 - IAmAYak] Performing com.dummies.android.MainActivity activity launch
    [2011-08-29 12:44:53 - IAmAYak] Automatic Target Mode: Preferred AVD '2_2_Default_HVGA_NoSD' is not available. Launching new emulator.
    [2011-08-29 12:44:53 - IAmAYak] Launching a new emulator with Virtual Device '2_2_Default_HVGA_NoSD'

    Any ideas?
Search tags for this page

android automatic target mode is not available

,

automatic target mode: preferred avd droidx is not available

,

automatic+target+mode:+preferred+avd++is+not+available.+laun

,

eclipse preferred avd is not available

,

preferred avd nexus is not available