Strange GMail Problem

Discussion in 'cvpcs' started by VivianC, Aug 13, 2010.

  1. VivianC

    VivianC Member

    Joined:
    Jul 19, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Burbs north of Chicago
    Ratings:
    +0
    Hi all,

    Since I upgraded to 1.0, I've been having an issue with GMail. It alerts me when new mail arrives and I can read them but when I try to delete them, it deletes on the phone but not on the main site. When I log in from home later, all those messages are still there and not flagged as read.

    I have a Moto Droid running Sapphire 1.0 with the gapps 1.0 and black bar mods. All the sync options I can find are turned on but the sync only seems to be working one way.

    Any thoughts?
     
  2. cereal killer

    cereal killer Administrator
    Staff Member

    Joined:
    Oct 29, 2009
    Messages:
    11,397
    Likes Received:
    1,279
    Trophy Points:
    558
    Location:
    Austin, TX
    Ratings:
    +1,426
    Current Phone Model:
    Nokia Lumia Icon
    go into settings/manage applications find gmail in the Running or All column and clear data.

    I usually force stop as well.
     
  3. VivianC

    VivianC Member

    Joined:
    Jul 19, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Burbs north of Chicago
    Ratings:
    +0
    Thanks for the quick response. That worked and know I know a new trick!
     
  4. GoGators

    GoGators Member

    Joined:
    Nov 8, 2009
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I had the same issue, and knew this trick, however, I had one pesky email that would not go away. I would delete it, clear data, and a few minutes later, I had new mail. I could not actually see the unread message on my phone until I cleared data and it reloaded, then there it was, that same one email. I did not do the force stop though. I have tried that and it is gone again (for now). Thanks for the additional tip!
     
  5. aminaked

    aminaked Silver Member

    Joined:
    Jan 10, 2010
    Messages:
    2,183
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    California, USA
    Ratings:
    +0
    There's "Gmail" and then there's "Gmail storage". Gmail storage has usually been the key when clearing data. Clearing Gmail data/cache might also be needed for some problems.
     
  6. raven1911

    raven1911 Member

    Joined:
    Nov 22, 2009
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I was having the same problem, although I could not send emails either for some reason. I hit send and the email just hangs saying sending..... and never sends it. I cleared the data, so hopefully that will help with my problem?
     
  7. aminaked

    aminaked Silver Member

    Joined:
    Jan 10, 2010
    Messages:
    2,183
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    California, USA
    Ratings:
    +0
    I've had this happen when sending an attachment. Sometimes you can just go to the Outbox and delete the stuck message. If that doesn't work, clearing "Gmail storage" data will.

    Whenever I have to send an attachment, I invariably choose K9 over the Gmail app (I use both) because of this bug.
     
  8. cereal killer

    cereal killer Administrator
    Staff Member

    Joined:
    Oct 29, 2009
    Messages:
    11,397
    Likes Received:
    1,279
    Trophy Points:
    558
    Location:
    Austin, TX
    Ratings:
    +1,426
    Current Phone Model:
    Nokia Lumia Icon
    yes my fix above will work for this issue as well.
     
  9. TRIKOTRET

    TRIKOTRET Active Member

    Joined:
    May 25, 2010
    Messages:
    1,458
    Likes Received:
    6
    Trophy Points:
    38
    Ratings:
    +6

    It does fix it but every now and then I will still get that problem. its annoying to keep doing the fix :icon_evil: