1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Strange DNS Behavior on GPA14

Discussion in 'Bugless' started by Urugami, Apr 22, 2011.

  1. Urugami
    Offline

    Urugami New Member

    Joined:
    Apr 27, 2010
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    0
    Shortly after I got my OG :motdroidhoriz:, I wrote some scripts to download podcasts. This worked fine for quite a while, but since I installed GPAxx, it doesn't work. I don't know whether it's GPA, the kernel, or just Gingerbread, but I can no longer wget files by domain name. It used to work on earlier BBs, and in Sapphire, but now that I've switched to GPA, whenever I try my scripts, or new commands, it goes like this:
    =================================
    # wget http://www.domain.com/path/file.ext
    wget: bad address 'www.domain.com'
    =================================

    However, if I ping the domain first to get the IP address of the domain, and then use that in wget, it'll work:
    =================================
    # ping www.domain.com
    ping www.domain.com (74.125.65.105) ...
    ...normal ping lines here...
    >break<
    # wget http://74.125.65.105/path/file.ext
    downloading file.ext
    ...100%...
    done
    #
    =================================

    The link to the files is still the same, and I can download them if I replace Domain with IP, but it's like wget doesn't know how to resolve a domain name into an IP address anymore. Any ideas?

    Thanks,
    Urugami
Search tags for this page
ping bad address www.google.com android
,

wget: bad address