Strange Behavior with Scaling Governor, 1.0.0

Discussion in 'cvpcs' started by sjkellyfetti, Aug 8, 2010.

  1. sjkellyfetti

    sjkellyfetti New Member

    Joined:
    Aug 8, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Albany, NY USA
    Ratings:
    +0
    Hi,

    I just rooted my Droid last night, and went straight to Sapphire 1.0.0 after reading about it Droid-Life. I like it a lot so far (compared to stock 2.1), though I admint that while I understand the concept of what I've done, I am not exactly sure what to do with it yet, which leads to this odd behavior (not sure if it is a bug or due to my lack of understanding and button mashing instincts).

    I was messing around in the GEM Settings earlier today and found my way to the Scaling Governor (Settings > Gem Settings > Performance > Scaling Governor).

    I saw it was set to ondemand, and looking at the settings I thought "hmmmm, powersave. That sounds like a good way to scale to CPU to help conserve battery...". So I jumped in and changed the setting. Like you do... Things were running along as per normal, until I ran into the music rocker bug (which I see I responded to incorrectly after reading about it here).

    When it started skipping, I was getting ready to go into a restaurant to eat, sitting in my car. I long pressed the volume by mistake as I was unlocking it to stop the playback of ACast, which somehow started the Meridian player. When it freaked out and started skipping songs, I unlocked the phone and tried closing Meridian from the app, but it relaunched when the track changed. I then tried Advanced Task Killer, but it kept coming back still. So I rebooted the phone and went to eat.

    While it rebooted, it was going very slowly. The Sapphire boot animation was up for maybe 20-25 seconds (normally it is about 7-8 seconds on my phone). It seemed eternal. When it finally came up to the lock screen, I attempted to unlock it, but everything was going very slowly. The lock button stuttered (graphically) while trying to unlock it and it didnt take, but I tried slower and it worked. Immediately the following message popped up:

    Sorry! (pop-up title)
    Process System is not responding.
    [Force close] [Wait] [Report] (buttons)

    It's modal so you couldn't do anything but deal with it, so I hit Wait, not wanting to FC the OS (I have learned when the message is general and vague like that (referencing some System I am not familiar with), it is usually related to the OS). The message went away, and the desktop came up. When I went to try anything, it was like my phone was gummed up with molasses. Everything reacted very slowly. Any screen where I needed to scroll took a visiblly long pause to react to the touch screen. I freaked out. What the heck had I done to my phone?!?

    Fearing I would have to reinstall the ROM with another wipe and format, I thought back to the changes I had made today. I uninstalled a couple of apps that I had put on today and rebooted a couple of times (with identical results) before I recalled that I had changed the Scaling Governor, and also that some of the GEM settings said on them that they required a reboot to take effect. I quickly (as quickly as you can go while wading through molasses) changed it back and rebooted. Presto! Changeo! The phone rebooted in the normal time, and behaved as it had previously. I have since repeated this behavior.

    So, is this a bug, or am I doing the wrong thing?

    As for the music rocker issue, I am so not used to that functionality yet - is there a way to disable it? I may prefer that since I mostly listen to hour long podcasts during my commute and don't have a general need to FF in my listening

    ~Skells
     
  2. ty_

    ty_ Member

    Joined:
    Jul 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    oh boy, you ready for this?

    its the scaling governor.
    Powersaver runs it on your MINIMUM SPEED. which was defaulted at 125 Mhz (assuming)


    basically its the opposite of performance, which always runs it at the maximum speed.


    its in a sense SetCPU but doesnt use memory because it only changes it at the boot.
    and it also doesn't monitor so it saves battery.
    What i think you were looking for was conservative. this is like ondemand, which is the default, but is more left than right, and likes lower speeds but will bump up if needed too.

    just go back to your settings and change it to ondemand again.

    easyFix__

    ty.

    EDIT:
    and now i feel stupid because i decided to go back and actually READ the rest and realized you fixed everything. >>
    well hopefully i taught you something new.
    and all was not wasted.
    the music bug i can't help with.
    but the bug you think is there is just your curiousity of a new ROM. :)

    EDIT 2:
    read: http://www.droidforums.net/forum/cvpcs/66803-built-cpu-control.html#post700552
     
    #2 ty_, Aug 8, 2010
    Last edited: Aug 9, 2010
  3. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    So do you guys leave Sapphire's Scaling Governor on? I disabled it since I'm using SetCPU but maybe I'm doing it wrong? Only been running Sapphire a few days now so not really sure what the best way to set that is. I did read cvpcs's post that the governor is not intended to replace SetCPU but I'm not sure if I'm sabatoging myself by turning it off completely.
     
  4. sjkellyfetti

    sjkellyfetti New Member

    Joined:
    Aug 8, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Albany, NY USA
    Ratings:
    +0
    I suppose then that what happened makes sense. OK, now I know. I'll give conservative as shot and see how that does. Thanks!

    Skells
     
  5. pdroid

    pdroid Silver Member

    Joined:
    Mar 4, 2010
    Messages:
    2,252
    Likes Received:
    7
    Trophy Points:
    103
    Location:
    Philly
    Ratings:
    +7
    I have also disabled it as I am using setcpu
     
  6. mjones73

    mjones73 Member

    Joined:
    Jul 10, 2010
    Messages:
    449
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I disabled it in favor of SetCPU due to profiles.
     
  7. wingdo

    wingdo Active Member

    Joined:
    Feb 17, 2010
    Messages:
    1,036
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Chicago
    Ratings:
    +1
    Just a reminder that if you are not using setcpu and are using sapphire itself to make these changes to the speeds and governors, they do NOT take effect until the next restart. This is why you noticed the issue only after the restart.
     
  8. ty_

    ty_ Member

    Joined:
    Jul 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    i decided to disable the scaling governor because i wanted to see how my battery life was without running BOTH.

    So i'm using just SetCPU right now, its not that bad. i haven't been using my phone very much but it's nice so far.

    OH ****.
    ALARM IS GOING OFF ON THE BOAT.
    ILL LET YOU KNOW HOW IT GOES LATER.
    BEEEEEEPPPPP
     
Search tags for this page

android+userspace+scaling+governor scaling min

,

scaling governor for android phones