Still having g issue with ok Google not responding on lock screen

Discussion in 'Moto Z2 Force' started by SMYDSMITH, Nov 23, 2018.

  1. SMYDSMITH

    SMYDSMITH Active Member

    Joined:
    Jul 4, 2010
    Messages:
    806
    Likes Received:
    124
    Trophy Points:
    43
    Ratings:
    +131
    Current Phone Model:
    Motorola Turbo 2
    Anybody have a long term fix for this

    Sent from my Moto Z (2) using Tapatalk
     
  2. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    Mine works fine. What exactly is the issue?

    Sent from my Moto Z (2) using Tapatalk
     
  3. SMYDSMITH

    SMYDSMITH Active Member

    Joined:
    Jul 4, 2010
    Messages:
    806
    Likes Received:
    124
    Trophy Points:
    43
    Ratings:
    +131
    Current Phone Model:
    Motorola Turbo 2
    On Z2 force if I do ok Google it still wants my fingerprint. I remived all device admins except for Google. No work policies

    Sent from my Moto Z (2) using Tapatalk
     
  4. bruben7886

    bruben7886 Diamond Member

    Joined:
    Dec 6, 2011
    Messages:
    1,735
    Likes Received:
    1,349
    Trophy Points:
    1,513
    Ratings:
    +1,416
    Are you running a different launcher. I use Nova.... Mine don't work either. Still not giving Nova up

    Sent from my Moto Z (2) using Tapatalk
     
  5. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    If everything is setup correctly in the Google app, using the stock Launcher, you will automatically have a Trusted Voice entry in the Security > Smart Lock settings.

    The Moto app on the Z2 phones is different than previous, since these phones shipped with Assistant installed and not the old Google Now. The new Moto app doesn't offer OK Google commands. It provides Show Me voice commands that perform some hands free functionality. After setting everything up in the Moto app and realizing that it only had Show Me functionality I deleted my Voice Model, rebooted and started over. I then setup my Voice Model and OK Google functionality within the Google app. That creates a Trusted Voice entry and my phone automatically unlocks with my voice using OK Google commands.

    If yours doesn't work I would recommend deleting your Voice Model, reboot and start over. But do not setup Voice in the Moto app, do it in the Google app.[​IMG]

    Sent from my Moto Z (2) using Tapatalk
     
    • Like Like x 1
  6. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    I also noticed that if everything is setup correctly the Moto App > Moto Voice section will already have the Voice Security option slid to ON. I don't remember if I turned that on manually or if it was automatic after setting up OK Google voice in the Google app. In either case, the Google app has an option to unlock with voice commands AND the Moto app has an option to unlock with voice commands. Both are set to ON for me and I can unlock my phone with OK Google voice commands.[​IMG]

    Sent from my Moto Z (2) using Tapatalk
     
    • Like Like x 1
  7. bruben7886

    bruben7886 Diamond Member

    Joined:
    Dec 6, 2011
    Messages:
    1,735
    Likes Received:
    1,349
    Trophy Points:
    1,513
    Ratings:
    +1,416
    I'll give it a shot Sajo. Thanks!


    Sent from my Moto Z (2) using Tapatalk
     
  8. SMYDSMITH

    SMYDSMITH Active Member

    Joined:
    Jul 4, 2010
    Messages:
    806
    Likes Received:
    124
    Trophy Points:
    43
    Ratings:
    +131
    Current Phone Model:
    Motorola Turbo 2
    I use Nova as well I find that if you toggle setting for ok Google in various places it works sometimes in reboot sometimes not. If any one has a permanent fix let me know

    Sent from my Moto Z (2) using Tapatalk
     
  9. SMYDSMITH

    SMYDSMITH Active Member

    Joined:
    Jul 4, 2010
    Messages:
    806
    Likes Received:
    124
    Trophy Points:
    43
    Ratings:
    +131
    Current Phone Model:
    Motorola Turbo 2
    Ok Google responds when I talk but if screen is locked it asks for fingerprint. If unlocked it works fine. ????

    Sent from my Moto Z (2) using Tapatalk
     
  10. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    I think the permanent fix is to use the stock Launcher, or something other than what you are using now. It works fine with the stock Launcher

    Sent from my Moto Z (2) using Tapatalk
     
    • Like Like x 1
  11. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    Have you contacted the dev team for that Launcher to ask them why this doesn't work, but does work on a stock phone?

    Sent from my Moto Z (2) using Tapatalk
     
  12. SMYDSMITH

    SMYDSMITH Active Member

    Joined:
    Jul 4, 2010
    Messages:
    806
    Likes Received:
    124
    Trophy Points:
    43
    Ratings:
    +131
    Current Phone Model:
    Motorola Turbo 2
    I just turned on the show me Moto setting again. Had it off as I don't find it as useful now ok Google works 65% of the time as opposed to 0-20 and show me works less often . I wonder if it's a Nova glitch with either ok Google or Moto show me app. Hmm also have rebooted yet to see if I have to reset after rebooting. to be continued.

    Btw I haven't used the native Android desktop in Android in years and like the Nova customizations. I'll have to check out stock Android on a pixel and see if I like it. Allot of people have been switching to pixel and even more with Samsung I hope Moto/Lenovo come on with a blockbuster Z3 force that can surpass or match them at least. Although I love my Z2 force I want a Z3 model equivalent and U haven't heard of any definites from Moto and Moto mods seem to be getting scarce unless they are bringing on a new set if Moto mods and. A new direction?

    BTW I now in an average busy day when not near a charger burn through 2 turbo Moto mod charges plus regular battery. BTW sprint had the turbo Moto mod chargers on clearance for less than half if what they are on eBay and Moto itself is out of stock. Thinking about buying a few more before they are sold out.

    Any rumors on the Z3 force?

    Sent from my Moto Z (2) using Tapatalk