Something SERIOUSLY wrong w/ 0.6.1 battery life

Discussion in 'Bugless' started by bekyndnunwind, Dec 29, 2010.

  1. bekyndnunwind

    bekyndnunwind Member

    Joined:
    Apr 29, 2010
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Central New York
    Ratings:
    +0
    Something SERIOUSLY strange w/ my 0.6.1 battery life ...

    1.) When I upgraded from 0.5 to 0.6.1, my battery life went from 20+ hours to ~10...

    2.) When my battery gets to 5%, I can still use the phone for hours before it dies . I can even play 50+ minutes of Youtube videos before it will finally shut down.

    3.) My phone's charge frequently jumps from 50% to 20%...

    Thinking it was a battery calibration issue, I deleted the batterystats.bin file after my phone reached 100% charge, and let it fully discharge before recharging it for a few days now. So far this has not fixed the issues I am seeing, but I will report back if things return to normal.

    I reverted to 0.5 and 0.4 to compare battery life and they seem to work like they should (and always have).

    I redownloaded/reflashed 0.6.1 (wiped 4 times) and tried multiple kernels including stock.

    I ordered a NEW replacement battery and it has displayed the same problems as my factory batt. I even checked the voltages - they correctly match the ranges I should be seeing for a good battery.

    HELP !?!?!
     
    #1 bekyndnunwind, Dec 29, 2010
    Last edited: Dec 29, 2010
  2. thomasshawn

    thomasshawn New Member

    Joined:
    Jun 21, 2010
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    +1

    same issues here
     
  3. FunnelWeaver

    FunnelWeaver Member

    Joined:
    Apr 24, 2010
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    As stated in my thread, I'm experiencing very similar issues.

    I am now nearly certain that this is an issue that lies within Android 2.2.1.
     
  4. takeshi

    takeshi Silver Member

    Joined:
    Nov 29, 2009
    Messages:
    4,581
    Likes Received:
    0
    Trophy Points:
    151
    Ratings:
    +0
    It could be but it's not an issue across the board so there's more to it than just Android 2.2.1 or BB 0.6.1. What do you all have in common?

    FWIW, I have no battery life issues. Battery life seems better with 0.6.1 for me.
     
  5. gsDroid

    gsDroid Member

    Joined:
    Dec 1, 2009
    Messages:
    513
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Colorado
    Ratings:
    +3
    It is perplexing how pretty much identical handsets following the same procedures to install a custom rom have such disparate results. My battery life was excellent under v0.5 and it is even better on v0.6.1. I can't believe how long my battery lasts under light/moderate loads. I'm running the stock kernel.
     
  6. bekyndnunwind

    bekyndnunwind Member

    Joined:
    Apr 29, 2010
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Central New York
    Ratings:
    +0
    Just wondering how often you have to charge your phone...
     
  7. Mikosh

    Mikosh New Member

    Joined:
    Oct 20, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bronx, NY
    Ratings:
    +0
    +1 for this. I can get about 2 or 3 hours on the 5% mark (x in battery icon). And it loves to jump from 50 to 20, tried calibrating as well....No luck
     
  8. gsDroid

    gsDroid Member

    Joined:
    Dec 1, 2009
    Messages:
    513
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Colorado
    Ratings:
    +3
    I can go a day and a half between charges. I like to let it get to 15% or so before I charge. I do turn off the phone at bedtime and turn it on when I wake up. I do mostly wifi browsing, a few phone calls, reading and sending emails. I am totally impressed with 0.6.1 performance and battery life. Must admit, when I get locked into an Angry Birds session, my battery suffers.
     
  9. peteralfonso

    peteralfonso Premium Member
    Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    What kernels are you guys running? I am running BB EXACTLY as it comes and have insane battery life (not just saying that because I make the ROM).
     
  10. bekyndnunwind

    bekyndnunwind Member

    Joined:
    Apr 29, 2010
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Central New York
    Ratings:
    +0
    Hi Pete!

    Kudos to you, I don't think it is a problem with the ROM specifically because other people running 2.2.1 android are experiencing this as well. LOVE your ROM and appreciate all the work you put into these quality releases :)

    I am currently using LFY 900mhz 6.5 kernel, I will put the stock on back on to test it out. Is the stock kernel the LFY 800mhz 6.5 kernel ?
     
  11. GDO7

    GDO7 Member

    Joined:
    May 11, 2010
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Texas
    Ratings:
    +0
    Pete, I amrunning the stock kernel and experienced the same thing. I just did a fresh install and am trying some things out. After I did the initial install I realized that the market didn't maintain all of my apps so I backed up 0.6.1 and installed my 0.5 backup so I could remember all the apps that I had. I would have used Titanium Backup, but I had problems with it early on (using it now though because it has gotten WAY better). When I reinstalled my 0.6.1 backup, I started having the battery issues.

    I just started over this morning with a fresh and clean install. Wiped 3 times and a 4th for good measure and am currently seeing what happens. I have been off the charger for 2 hours now and still at 100% with light use so it is looking good.

    There has to be a common denominator between all of us that had the bad experience, but I haven't a clue of what it is. Reguardless, I will be a Bugless Beast user for life. You do great work, man!
     
  12. FunnelWeaver

    FunnelWeaver Member

    Joined:
    Apr 24, 2010
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'm running ChevyNO1's ULV 1100MHz kernel. I've also tried Slayher's kernels and experienced the same problems.