Smart Actions conflicting?

Discussion in 'Droid RAZR' started by eddie7, Jan 14, 2012.

  1. eddie7

    eddie7 Member

    Joined:
    Dec 26, 2011
    Messages:
    107
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    AZ
    Ratings:
    +4
    I started with the basics home and work. But I tried setting 1 up for weekend and it keeps my phone from connecting to my home wifi. Is there a way to make Home override all others?

    Sent from my DROID RAZR using DroidForums
     
  2. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,808
    Likes Received:
    4,750
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,289
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    <br>
    <br>
    There must be something wrong with your triggers. Either they aren't all being satisfied on the HOME WIFI Smart Action, or you have a conflict. You have to be sure that ALL of the triggers are active on at least ONE of the Smart Actions, and that there are not more than 1 Smart Action which has ALL of the triggers active at the same time, if the actions on any two or more Smart Actions are in any way conflicting.<br>
     
    #2 FoxKat, Jan 14, 2012
    Last edited: Jan 14, 2012
  3. eddie7

    eddie7 Member

    Joined:
    Dec 26, 2011
    Messages:
    107
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    AZ
    Ratings:
    +4
    Triggers should be fine. Home is set to location. Weekend is set to a time frame. The plan was whenever I am at home I want to my Wifi. Seems like an "away from location" would be a useful trigger. Anyone else have any ideas?
     
  4. techgov8

    techgov8 Member

    Joined:
    Jan 12, 2012
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Sometimes they conflict when one action or trigger overlaps another one.Mine still work when they do this. You can check and see which ones are running in smart actions. You have your wifi on correct? Cause the wifi is needed for GPS location to be received and to see where you're located
     
  5. pinoy_92

    pinoy_92 Member

    Joined:
    Jan 5, 2010
    Messages:
    266
    Likes Received:
    14
    Trophy Points:
    18
    Ratings:
    +14
    i found that making a separate rule for my data connection works the best without conflicting with anything.

    im doing programming in school and i found out that sometimes its better to separate some rules instead of putting all of it in one.

    this is my home/wifi setup:

    Home

    Triggers: Location
    Actions: ringer volume 50%, display timeout 2mins, brightness 100%, background sync on

    Wifi

    Triggers: wifi connection
    actions: dellular data disable.

    hope this helps!
     
    #5 pinoy_92, Jan 15, 2012
    Last edited: Jan 15, 2012
  6. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,808
    Likes Received:
    4,750
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,289
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Question, is Weekend also set to turn off WIFI?

    The possible issue here is that Weekend is ONLY set to a timeframe, so it doesn't matter whether you are home and have WIFI or anywhere else for that matter. In other words, Weekend will activate EVEN WHEN YOU ARE HOME, and if it conflicts with the Home setting by turning off WIFI, you don't get WIFI at home. It's that simple.

    I use several alternatives, but the best one I've found for identifying home is to use the WIFI itself. Since WIFI is ON all the time on the home wireless router, and since it can only be seen within a certain distance around the home, it works better than even Location to identify when I am home. Simply make a trigger that sees your WIFI connection to identify home. You kill two birds with one stone. Also, use Verizon's WIFI Auto-On tool to turn on WIFI on the phone when you are in areas where there is a known WIFI connection (like home), and by virtue of it's design it turns OFF the WIFI when you leave home, giving you the "away" you're looking for.

    This arrangement works perfectly for me since I have WIFI at work and at home, but obviously don't have it in the car. If you want, I can send the full layouts to you but it should be rather common sense at that point.

    I agree that there needs to be more reverse triggers to the forward triggers already found, but I am hoping they know this and will bring them on board. For instance, you can detect whether the phone is NOT charging, as well as charging, and even what type of charger. You can detect whether you DON'T have headphones plugged in or do, but can't determine if you are NOT at home by location. This is why if you have WIFI at home, you should be using it to trigger home, unless you want Cellular data for something specific.

    Keep Location as a trigger for times when you know there is NO WIFI available, such as at the Movies, and let it trigger things like Ringer Volume off, screen Brightness to Automatic, and Display Timeout to 15 seconds, for instance.

    Of course everyone knows that WIFI is (currently) required to be ON for Smart Actions to work properly. We'll have to see if that roadblock is lifted in the next iteration of Smart Actions.
     
    #6 FoxKat, Jan 15, 2012
    Last edited: Jan 15, 2012
  7. techgov8

    techgov8 Member

    Joined:
    Jan 12, 2012
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Not ALL smart actions require wifi. I have one set so when my display is off and its not charging my GPS and data go off. If you use locations then wifi is needed for those
     
  8. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,808
    Likes Received:
    4,750
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,289
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Agreed, but my comment was "required to be ON for Smart Actions to work properly." You will agree that SA doesn't work properly (i.e. 100%) if WIFI is off, however it will work for many functions with it off. I also have SAs that don't use WIFI On (such as when I am in my car), but if you are using Location as a trigger (as this OP was), Smart Actions REQUIRES WIFI to be on. This is why using Verizon WIFI On works well to circumvent that limitation. When I leave home, Verizon WIFI Auto-On turns the WIFI off on my phone and that lets my car profile take over. For my phone, WIFI is only on when either at Work or Home. Otherwise it's off and I still use SAs for other purposes.
     
    #8 FoxKat, Jan 15, 2012
    Last edited: Jan 15, 2012
  9. techgov8

    techgov8 Member

    Joined:
    Jan 12, 2012
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Agreed. I recently turned my wifi policy to turn off when the phones asleep which helps a lot as well on battery
     
  10. unrl

    unrl New Member

    Joined:
    Jan 13, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Funny thing about Smart Actions, I just did a Battery Extender one. What I selected was Triggers - Display off and No Battery Charging, Actions - Turn Off GPS and turn off Background data sync.

    Once I did that, I told my mate to WhatsApp me once I turn my screen off. Turned my screen display back on, and I saw his message on WhatsApp. What I'm curious about is, by setting these triggers, my 3G should be turning off and not receiving any messages from WhatsApp, anyone know why? Please help!

    When I looked into Smart Actions again, it says "Ready" as the status.
     
  11. pinoy_92

    pinoy_92 Member

    Joined:
    Jan 5, 2010
    Messages:
    266
    Likes Received:
    14
    Trophy Points:
    18
    Ratings:
    +14

    You have to turn off your data (e.g. wifi and 3g/4g) and even then you can still receive calls and text messages.

    Sent from my DROID RAZR using DroidForums
     
  12. unrl

    unrl New Member

    Joined:
    Jan 13, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    But there's no options in Smart Actions to do that unfortunately?

    The thing is, when I set that trigger, my 3g actually turns off, and when I turn my display on again, my 3g icon is grey in colour and turns blue (when its activated). So as you can see, when I turn my display off, my 3g SHOULD be turning off hence not being able to receive ANY WhatsApp messages at all. WhatsApp is different from normal txts or calls, normal txts and calls don't require 3g to function.
     
Search tags for this page
android phone smart action conflict
,

conflicting smart actions

,
juice defender whatsapp conflict
,
smart action conflict?
,
smart actions turn off wifi turn on mobile data conflict