Small Lag When Switching Screens

Discussion in 'UltimateDroid' started by czonin, Dec 8, 2010.

  1. czonin

    czonin Member

    Joined:
    Apr 1, 2010
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Island
    Ratings:
    +0
    Loving 2.4 so just wanted to say thanks to BD and everyone else. Just 1 thing that annoys me that I had in 2.3 too. When im scrolling across my home screens I get a small lag spike for a second before it goes to the next screen. Is there an option in UD Settings or ADW that I could change that would fix this?
     
  2. bendystrawboy

    bendystrawboy Member

    Joined:
    May 27, 2010
    Messages:
    797
    Likes Received:
    2
    Trophy Points:
    18
    Ratings:
    +2
    did you use spare parts to speed up animations?
    i dont use adw for this reason, but it wasnt nearly as bad in 2.4 as it was previously for me.
     
  3. RaptorKC

    RaptorKC Member

    Joined:
    Feb 3, 2010
    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Same happened to me in 2.3. hours debugging finally found that having 'scrollable widgets' enabled was causing this. try unchekcing it in the ADW launcher config.
     
  4. czonin

    czonin Member

    Joined:
    Apr 1, 2010
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Island
    Ratings:
    +0
    Disabling scrollable widgets worked at first but then the same lag started again.
     
  5. czonin

    czonin Member

    Joined:
    Apr 1, 2010
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Island
    Ratings:
    +0
    Bump....Anyone have ideas on what can fix this?
     
  6. CD95YJ

    CD95YJ Member

    Joined:
    Nov 2, 2010
    Messages:
    868
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado, USA
    Ratings:
    +1
    You do know you have a desktop scroll speed setting under the screen preferences option of the adw settings right. I have mine cranked to almost 0 as well as bounce or bound... whatever its called and my screens move fast with no lag.

    Sent from my DROIDX using DroidForums App
     
  7. giant25

    giant25 Member

    Joined:
    Jan 4, 2010
    Messages:
    333
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    CA
    Ratings:
    +9
    Current Phone Model:
    Droid Turbo
    Are you using a calendar widget? I'm using android agenda widget and I notice if I have two separate calendars on separate screens that I get a lag, so I've removed one for now until I figure it out.
     
  8. czonin

    czonin Member

    Joined:
    Apr 1, 2010
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Island
    Ratings:
    +0
    Ya I knew about them but didn't think they would have any effect on the lag. Just dropped both the settings close to 0. Gonna let it run for awhile, hopefully it fixes it. Thanks!
     
  9. CD95YJ

    CD95YJ Member

    Joined:
    Nov 2, 2010
    Messages:
    868
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado, USA
    Ratings:
    +1
    Yeah with the scroll speed set slower there will be a pause when you slide your finger across the screen if you slid too fast. I can slide across the screen very fast with no lag at the settings I have.

    Sent from my DROIDX using DroidForums App
     
  10. RaptorKC

    RaptorKC Member

    Joined:
    Feb 3, 2010
    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yeah, the scrollable widgets really isn't the issue. with more digging the fastest for my phone:
    Under System Preferences:
    Wallpaper hack = on
    Scrolling Cache = disabled

    Under Screen preferences:
    Desktop scrolling speed = 0