Should I get a new charger? Phone is on a fritz!

Discussion in 'Android General Discussions' started by foolie, Jan 11, 2011.

DroidForums.net is the premier Android Forum - Registered Users do not see these ads. Please Register - It's Free!
  1. foolie
    Offline

    foolie Member

    Joined:
    Oct 30, 2009
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SJ, CA
    Ratings:
    +0
    I've been using aftermarket chargers for quite some time without problem and recently in the past week my phone has been going on the fritz! At times the right side of the screen is unresponsive, other times it makes random touchscreen presses all over the place. Both of these scenarios take place while the phone is plugged and unplugged. On times when i fully drain the battery and plug it into the car charger the phone works okay though but it still has those issues though not as frequent. The current charger I'm using is a 5V 500mA aftermarket so I'm wondering whether you guys think its guts are fried or should I go pick up an OEM one from VZW?

    Thanks fellas.
  2. hemorrdroid
    Offline

    hemorrdroid Member

    Joined:
    Feb 2, 2010
    Messages:
    735
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Missouri
    Ratings:
    +0
    The fact that it does this while unplugged makes me worry.
  3. foolie
    Offline

    foolie Member

    Joined:
    Oct 30, 2009
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SJ, CA
    Ratings:
    +0
    yeah, what's odd is that the problem first started while i had it plugged to my ps3 for usb using the original moto cable... anyone have any thoughts on my situation though?
  4. Ghostwheel
    Offline

    Ghostwheel Member

    Joined:
    Jan 21, 2010
    Messages:
    410
    Likes Received:
    7
    Trophy Points:
    18
    Location:
    Cincinnati
    Ratings:
    +7
    A while back, I bought the univeral car charger from Verizon, and it started all kinds of craziness on my D1. Only a factory reset fixed it, and it's been fine ever since, using only the OEM Motorola wall charger it came with. I returned the car charger and vowed to wait until Moto came up with their own OEM. I see they have, but I haven't grabbed one yet. Guess I'm a little scared after that incident.
Search tags for this page

new phone on the fritz

,

quick fix for droid x on the fritz

,

windows phone on the fritz