Screen-off music controls

Discussion in 'Project Elite' started by phenix, Jan 2, 2011.

  1. phenix
    Offline

    phenix New Member

    Joined:
    Aug 30, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Is anyone else having issues using the volume rocker to control music with the screen off? Sometimes (not always, but usually) when I hold the volume down button to skip a track, it seems to stick and keep skipping after I let go. The only way to stop it is to reboot it seems. Has anybody else found a workaround?

    Sent from my Droid using Tapatalk
  2. burntorangefan
    Offline

    burntorangefan Member

    Joined:
    Aug 19, 2010
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Seattle, WA
    Ratings:
    +0
    phenix,

    I started to say I hadn't experienced this before on this ROM, but after testing it for 10 minutes I was able to replicate it as well. Actngrezy is the best dev at responding to issues, so I'm sure he'll follow up and check on this. Weird, because I listen to music often and hadn't had it happen until I tried to "force the issue."
  3. phenix
    Offline

    phenix New Member

    Joined:
    Aug 30, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yep I always wipe. I should also note that it doesn't seem to matter what app I use, it's happened with Pandora, last.fm, winamp, and the stock music player. Don't know if it was an issue when I ran pe3.5 but definitely an issue now.

    Sent from my Droid using Tapatalk
  4. sc4fpse
    Offline

    sc4fpse Member

    Joined:
    Dec 4, 2009
    Messages:
    341
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Pretty sure this same issue plagued cyanogen for the longest time, though it was eventually fixed.
  5. bazar6
    Offline

    bazar6 Premium Member Theme Developer Premium Member

    Joined:
    Dec 15, 2009
    Messages:
    678
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    MD
    Ratings:
    +10
    I turned that mod off after it did the same thing on other roms, but the problem I'm having is when the screen is on but is still 'locked', the three controls near the bottom don't do anything. Pause, skip back and next don't do anything.

    This isn't going to make me switch to another rom tho, I'm liking PEv4 more than I ever have any other.
  6. GirLuvsDroid
    Offline

    GirLuvsDroid Senior Member

    Joined:
    Feb 18, 2010
    Messages:
    1,551
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    Wilmington, DE
    Ratings:
    +1
    Actngrezy responded about the glitch in the volume rocker controls here: http://www.droidforums.net/forum/ac...rg83d-w-gingerbread-parts-32.html#post1151671.

    I tried to duplicate the problem you describe, bazar, but I can't. My music controls at the bottom of the lock screen are working consistently fine.
  7. bazar6
    Offline

    bazar6 Premium Member Theme Developer Premium Member

    Joined:
    Dec 15, 2009
    Messages:
    678
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    MD
    Ratings:
    +10
    Thanks. Theres so many pages to look through, I didn't see his post.

    This stinks. I'm using the Music 1x4 widget to control the music, and in PE's settings / Multimedia, the Vitrual Music Controls is set to "When Playing". I can't find anything else that could help in replicating, or in fixing this. If not, no worries. Like I said, minor thing for me, I'm not running to another rom just because of this.
  8. actngrezy
    Offline

    actngrezy Active Member Developer

    Joined:
    Mar 21, 2010
    Messages:
    1,074
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    delaware
    Ratings:
    +2

    I cannot replicate the music controls on lockscreen issue. They seem to wrok fine all the time but I did replicate the volume music controls. Ill work on fixing that. For the next release
  9. GirLuvsDroid
    Offline

    GirLuvsDroid Senior Member

    Joined:
    Feb 18, 2010
    Messages:
    1,551
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    Wilmington, DE
    Ratings:
    +1
    That's how I have my Virtual Music Controls set in Elite Settings, as well. Did you do a Titanium Backup restore? And if so, did you restore [SETTINGS/BLUETOOTH] Settings Storage 2.2.1? If you did, especially coming from another ROM, that may have caused weird conflicts with the Elite Settings functions. Try making a nandroid backup first, then go into Titanium Backup and wipe all data from that item (the one in green above) and reboot, then see if your music controls work. Just know before you do this that you may have to set all your other settings in Elite Settings again.
  10. bazar6
    Offline

    bazar6 Premium Member Theme Developer Premium Member

    Joined:
    Dec 15, 2009
    Messages:
    678
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    MD
    Ratings:
    +10
    No, I did a clean factory wipe (both files and cache options in SPRecovery) before installing this, with no restores.
    I think I've used TitaniumBackup maybe once. I prefer to use the nandroid in recovery to backup (and restore if i have to).

    But I did just do what GirlLuvsDroid recommended, backed up then wiped the settings/bluetooth, then rebooted. Now I see where I had a problem a little while ago: the home button, magnify button, and lock button don't work. The power button just turns off the display, no lock screen at all when I turn it back on; and I have no clue where this is in. (I'm using LauncherPro, but that's set to do the home button to the homescreen, but it doesn't) Should I just do the recover through TiBackup for that setting? - Then I'll be able to know if the lock screen controls work.
  11. GirLuvsDroid
    Offline

    GirLuvsDroid Senior Member

    Joined:
    Feb 18, 2010
    Messages:
    1,551
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    Wilmington, DE
    Ratings:
    +1
    You can try doing a TiBu restore of that setting and if the issues with the lock screen, etc. persist (I've never seen that result before, by the way), then I recommend restoring the backup you made before you wiped that setting.
  12. bazar6
    Offline

    bazar6 Premium Member Theme Developer Premium Member

    Joined:
    Dec 15, 2009
    Messages:
    678
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    MD
    Ratings:
    +10
    Restored that data file and the Home button and lock screen works now. Scared me for a second lol. But, controls on lock screen still don't work :/

    Thanks for helping, but I'm not gonna make a fuss about it, thought it was just something I didn't have toggled or a different option I had to use. I'll keep playing around with it and see if I can get it.
Search tags for this page
android control music screen off
,
android music controls swipe
,

android screen off music control

,

android track controls screen off

,
control music on android while screen is off
,
control music while android screen is off
,
htc m1 8 music skips during playing
,
reset android controls at bottem of screen