SBF after liberty not working?

Discussion in 'Liberty ROM D2' started by Joshmichael91, Feb 2, 2011.

  1. Joshmichael91
    Offline

    Joshmichael91 Member

    Joined:
    Apr 12, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have liberty 1.0 installed on my phone.

    my screen is hardly working and I need my phone replaced.

    I assume Liberty ROM will void my warranty so i need to flash back to stock and unrooted rom.

    to do that Im trying to use RSDLite to flash the 2.3.20 SBF.

    it went through the process and now appears to be stuck on the Liberty startup icon. It now shows the motorola M (which didn't before) but still doesn't seem to work.

    before I flashed the SBF i did a data and cache wipe but couldn't sign back into my google account due to broken screen.

    am I doing something wrong? is there any way I can fix this?


    Edit: also how am I going to get RSDLite to recongize my device now to try again?
     
  2. Jef
    Offline

    Jef Member

    Joined:
    Nov 6, 2009
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    That's just the Bootlogo which is NOT touched by SBFing.

    The easiest way to correct it install Liberty Tools from Market, and change the bootlogo back to Standard M.
     
  3. Joshmichael91
    Offline

    Joshmichael91 Member

    Joined:
    Apr 12, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    the motorola M does appear. but then after that it shows LIBERTY and has the spinning icon. which it appears to be stuck at

    are you saying the SBF did in fact work?
     
  4. Jef
    Offline

    Jef Member

    Joined:
    Nov 6, 2009
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Oh sorry, I thought it was the Boot Logo.

    The Spinning one is the Boot Animation. That should be gone once you properly SBF I beieve.

    I would SBF again to be sure.
     
  5. Joshmichael91
    Offline

    Joshmichael91 Member

    Joined:
    Apr 12, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    how? it's stuck at the Liberty icon just after the motorola M

    kinda like a boot loop.

    how do i get RSDlite to recongize my device TO sbf again?
     
  6. Jef
    Offline

    Jef Member

    Joined:
    Nov 6, 2009
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Set your Device into Flash (Bootloader) mode.

    Power it off, hold the volume up key and power on
    Connect USB to PC
    Restart RSD lite and it should detect it
     
  7. Joshmichael91
    Offline

    Joshmichael91 Member

    Joined:
    Apr 12, 2010
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    i'm assuming sense I was able to get past the motorola M that i am not bricked. so i did the above steps and RSDLite recongized a "S FLash" and says the following (in appropiate fields)

    port no: 1
    Port Type: USB
    ESN: N/A
    Status: phone[0000]: Creating Imagine File
    Excuted: 26% (at time of post)
    result: in progress

    my phone screen reads the same text as when I went into flash mode, rather than SW Update in progress or whatever it usually says

    is this looking good for me? shouldn't it recongize my device or is this all okay?
     
  8. Jef
    Offline

    Jef Member

    Joined:
    Nov 6, 2009
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    yes it sounds like you are flashing already.

    Just let it go to completion and it will reboot when it's done
     
  9. Big Ry
    Offline

    Big Ry Active Member

    Joined:
    Feb 4, 2010
    Messages:
    1,299
    Likes Received:
    10
    Trophy Points:
    38
    Location:
    Blacksburg, VA
    Ratings:
    +10
    lol i was having the exact same issue as you 10 minutes ago. when it says in RSD to manually reboot, follow these steps:

    unplug
    turn off (i had to pull battery)
    power up holding the X button
    you should see an android and a "!" logo
    hit the search button on the pullout keyboard to get to recovery
    wipe cache and data
    reboot

    that should work
     
  10. Jaxidian
    Offline

    Jaxidian Team FreeMyMoto Premium Member Developer

    Joined:
    Jun 26, 2010
    Messages:
    554
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Indianapolis
    Ratings:
    +0
    If you're stuck at the boot animation (and sometimes it takes 10 minutes to get past there after a flash), *usually* a battery pull followed by a wipe data/cache will fix the problem. Not always, but usually. If you are bricked (can't even get to the boot animation), then you can usually even then SBF again.