Rooted SU :( please help!!

Discussion in 'Android Hacks and Help' started by dfwdroid, Feb 19, 2010.

  1. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    hi i am running BB7.6 for a while now.
    i was looking around within the "superuser Permission" app and i pressed on a couple of the line ( 100xxx:10xxx 0:0 /data...etc ).
    now when i try to use the Terminal emulator i get "permission denied" when i type "su"...:( i feel really dumb right now

    Please can someone help me to get it back or undo what i did?

    PLEASEE:)
     
  2. mwhartman

    mwhartman Super Moderator/RS Premium Member

    Joined:
    Jan 15, 2010
    Messages:
    10,737
    Likes Received:
    12
    Trophy Points:
    153
    Location:
    South FL
    Ratings:
    +12

    This is above my pay grade but I'm thinking that somehow you deleted a permission. Additionally, I think that to repair, you will need to use SU with the terminal emulator and reenter one or more commands.

    I'm sure someone will provide you with the correct approach.

    Mike
     
  3. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0

    yup i think i deleted some permission since now i can't even use the terminal emulator and the SETCPU :( man this really suck ...wanna shoot myself.
    thanks for the reply though....:)
     
  4. jstafford1

    jstafford1 DF Super Moderator Rescue Squad

    Joined:
    Nov 15, 2009
    Messages:
    9,975
    Likes Received:
    686
    Trophy Points:
    228
    Location:
    Hebron, Oh.
    Ratings:
    +742
    Twitter:
    jstaff79
    Have you tried a nandroid restore?
     
  5. thebowers

    thebowers Premium Member Theme Developer Premium Member

    Joined:
    Nov 24, 2009
    Messages:
    2,547
    Likes Received:
    1
    Trophy Points:
    101
    Location:
    Iowa
    Ratings:
    +1
    Try rebooting and then open terminal. Type su and a permission window should appear. If not simply backup and restore.
     
  6. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I am about to do a nandroid restore....standby
     
  7. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    quick question, for the nandroid backup, which option should i chosse, advanced or latest?
     
  8. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    CASE CLOSED!!!! woot woot....i love NANDROID :) life is good again guys thanks for the input :) beer time ;)
     
  9. mwhartman

    mwhartman Super Moderator/RS Premium Member

    Joined:
    Jan 15, 2010
    Messages:
    10,737
    Likes Received:
    12
    Trophy Points:
    153
    Location:
    South FL
    Ratings:
    +12
    Glad you recovered. What option did you choose?

    Mike
     
  10. dfwdroid

    dfwdroid Member

    Joined:
    Jan 6, 2010
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0


    I did the restore advanced..once i rebooted things were back to normal:icon_ banana:
    so then i did an advance backup again to get the latest "good" backup just in case my finger wants to tap again:mad: LOL
     
  11. mwhartman

    mwhartman Super Moderator/RS Premium Member

    Joined:
    Jan 15, 2010
    Messages:
    10,737
    Likes Received:
    12
    Trophy Points:
    153
    Location:
    South FL
    Ratings:
    +12
    Thanks! It is nice to learn how folks handle these situations.

    Mike
     
  12. Backnblack

    Backnblack Premium Member Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    11,262
    Likes Received:
    17
    Trophy Points:
    453
    Ratings:
    +17
    Moved to correct sub-forum