ROM Loading Issues with SPRecovery

Discussion in 'Android Hacks and Help' started by Heero, Feb 13, 2010.

  1. Heero

    Heero New Member

    Joined:
    Nov 26, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello. I am submitting this thread in asking for assistance from the Droid community. I performed the rooting process for my phone and everything went smooth with no issues... I was able to root the phone, load Bugless Beast, etc. and it's working perfectly fine.

    However, the problem is that I decided to do the same for my friend's phone, doing exactly the same steps, but instead encountering many issues. I was able to root the phone and install SPRecovery, but everytime we try to load a ROM, it would give a "Nandroid exited with status 21, 25, or 28" error. The first time we got a ROM loaded, the phone kept rebooting, so we reverted back to a Nandroid Backup. We then tried another ROM, and since then, gives us errors. We have tried doing Data Wipes, Advanced Nandroid Restore, Install, renaming files to TGZ, etc. with no success. I'm not sure why everything worked fine for my phone, but for my friend's phone, it is giving us issues.

    One ROM actually worked, but it was an older version of the Smoked Glassed Theme ROM, which was already on my SDCard.. which I transferred to my friend's phone to perform the loading. However, all new ROMs that I download and copy over to the SDCard will give the status error... could there be a problem with downloading or copying the files to the SDCard? Not to mention that the phone has trouble a few times detecting the SD Card and reboots.

    I also checked to make sure he was coming from a 2.0.1 firmware. Mine was also 2.0.1 at the time.

    If anyone can help out, that would be appreciated. Thanks.
     
  2. shademar

    shademar Member

    Joined:
    Nov 28, 2009
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Berkeley
    Ratings:
    +0
    What version of sprecovery do you have loaded? It's currently .99.3b, and some roms need the newer versions. Also, did you do a complete wipe before trying to install?

    Finally, can you swap the sdcard temporarily and verify that your card works to check if that's the issue?
     
  3. natediddy1120

    natediddy1120 Silver Member

    Joined:
    Jan 4, 2010
    Messages:
    3,180
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    ???
    Ratings:
    +0
    Are you properly unzipping the ROM files before you place them in the nandroid folder?
     
  4. doug piston

    doug piston Premium Member Rescue Squad Premium Member

    Joined:
    Dec 19, 2009
    Messages:
    1,203
    Likes Received:
    4
    Trophy Points:
    38
    Ratings:
    +4
    open the unzip folder and put the folder you find in there in the nanodroid folder and try again
     
  5. Backnblack

    Backnblack Premium Member Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    11,262
    Likes Received:
    17
    Trophy Points:
    453
    Ratings:
    +17
    Moved to correct sub-forum.
     
  6. Heero

    Heero New Member

    Joined:
    Nov 26, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks I will try the above solutions.
     
  7. dbu

    dbu Member

    Joined:
    Feb 4, 2010
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fort Worth, TX
    Ratings:
    +0
    Sounds like you have a folder within a folder in your nandroid folder, or you aren't unzipping the .zips.