ro.build.version.sdk=??

Discussion in 'Android Hacks and Help' started by Benny, Feb 22, 2010.

  1. Benny
    Offline

    Benny New Member

    Joined:
    Feb 1, 2010
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    Alright, so to install Google Earth on your phone you can change ro.build.version.sdk=6 to ro.build.version.sdk=7 in the build.prop, although the downside to this is that DroidRootHelper does not work when you have ro.build.version.sdk=7 in build.prop. So is there any way to trick your phone into thinking its running 2.01 and 2.1? Can someone try ro.build.version.sdk=6-7?
  2. Topsy
    Offline

    Topsy New Member

    Joined:
    Dec 28, 2009
    Messages:
    677
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Rio Rancho, New Mexico
    Nope. Although you can modify your build.prop before you launch the appropriate app, it's an easy change can be done right on the phone.
  3. Benny
    Offline

    Benny New Member

    Joined:
    Feb 1, 2010
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    You can change it on your phone but you need to reboot before it takes effect.
    And I don't want to reboot every time I want to switch from Google Earth to DroidRootExplorer.
  4. Topsy
    Offline

    Topsy New Member

    Joined:
    Dec 28, 2009
    Messages:
    677
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Rio Rancho, New Mexico
    I'm pretty sure the dev has been asked many times to make his app compatible with 2.1, but I guess it wouldn't hurt to contact him again.
    He's required to have an email associated with the account he published the app with.
  5. Benny
    Offline

    Benny New Member

    Joined:
    Feb 1, 2010
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    Is it easily editable? Meaning is the settings for which versions the app is compatible with contained in an xml file? If it is, can any dev edit the DroidRootHelper.apk to be compatible with 2.1?
  6. Topsy
    Offline

    Topsy New Member

    Joined:
    Dec 28, 2009
    Messages:
    677
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Rio Rancho, New Mexico
    No you can't hack a market application, since they are signed at the time they are created.
Search tags for this page
build.version.sdk
,
change sdk version build prop
,
changing ro.build.sdk
,
edit ro.build.version.sdk= in build.prop
,
edit ro.build.version.sdk=8 to ro.build.version.sdk=17
,
how to modify ro.build.version.sdk
,
ragnarok on droid
,
ro build version sdk
,
ro. build. version. sdk
,
ro.build.sdk 15
,

ro.build.version.sdk

,
ro.build.version.sdk=10
,
ro.build.version.sdk=15
,
sdk version build.prop
,
xhange ro.build.version.release