Redraw delay

Discussion in 'Samsung Galaxy Nexus' started by jk8, Feb 12, 2012.

  1. jk8

    jk8 Member

    Joined:
    Jan 3, 2011
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I've had my Nexus for about three weeks and have noticed over the last few days that it takes longer and longer to redraw the home screen when coming out of an app. I have had none of the other problems I've read about, so I feel fortunate. I'm still locked and unrooted . Anyone else having this problem?
     
  2. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,077
    Likes Received:
    1,503
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,667
    Current Phone Model:
    Google Pixel
    In those three weeks have you restarted the phone?

    I ran a little test and noticed that after about a week and a half of the phone being on, it would slow down a bit. Did a restart and it was as snappy as it was out of the box. I think I had it up to close to 300hrs uptime. You can check the up time in your settings ---> about phone ---> status and it should be on the bottom.

    There are of course other things that apply to the slight delay (amount of apps, apps running, apps running in the background, widgets, etc.), but overall a restart is always good for a fresh restart.
     
    #2 dezymond, Feb 12, 2012
    Last edited: Feb 12, 2012
  3. Creed

    Creed Member

    Joined:
    Oct 26, 2011
    Messages:
    228
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This works perfect.

    In terminal emulator:

    type su and enter.
    Then type echo ro.HOME_APP_ADJ=1 >> /data/local.prop and enter.
    Then reboot.
    Now evaluate whether or not this fixes your lag.

    It basically places the home launcher as the top priority to keep in memory. I believe it is number 6 be default. This places it at #1 so it will be the last thing to kick out of memory.

    If you want to undo what this command does, simply remove that toggle from: /data/
    local.prop



    CREDIT: samsonite801