Really need help with this - Wifi at Work

Discussion in 'Motorola Droid' started by Canefan, Jan 11, 2010.

  1. Canefan
    Offline

    Canefan New Member

    Joined:
    Dec 27, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    When I connect to the Wi-Fi at work, my browser won't connect and says, "Web page not available". I talked with the IT department about it, and they said the phone is not allowing me to accept the wireless certificate, so even though I am connected to the wireless, I can't access the internet. My co-worker has an iPhone, and when he accesses the Wi-Fi for the first time each morning, his browser shows a pop-up that says "Accept Website Certificate - The certificate for this website is invalid. Tap accept to connect to this website anyway" and then he can select either "accept" or "cancel". When he hits "accept", the browser takes him to a page that says, "Welcome to the Cisco Wireless Network. Cisco is pleased to provide the Wireless LAN infrastructure for your network. Please login and put your air space to work." There is an "accept" button for him to hit, and then his browser has access to the Wi-Fi. My problem is that my browser is not showing the initial pop-up or taking me to the browser login page, it just says "Web page not available". The IT guys say there must be a preference or setting in my phone that will allow me to get these initial messages, but I can't find them anywhere. Any ideas would be greatly appreciated!
  2. bamfsig45
    Offline

    bamfsig45 New Member

    Joined:
    Nov 3, 2009
    Messages:
    895
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    ICT
    Have you tried Dolphin or Steel browser?
  3. Canefan
    Offline

    Canefan New Member

    Joined:
    Dec 27, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    Tried Dolphin. No Luck there. Had high hopes because you can change the identifier to either Desktop or iPhone. Same response. Not familiar with Steel Browser. I'll look at it.
  4. Canefan
    Offline

    Canefan New Member

    Joined:
    Dec 27, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    Same thing with Steel browser (nice btw). There are no settings that affect how the phone handles invalid certificates. The request fails on the redirect to the Cisco login page. This is a huge problem for me because my 3G reception is poor in the part of the building where I spend most of my time and the open Wifi network is readily available and superfast. It kills me that my iPhone and Blackberry colleagues can get on it no problem.
  5. MM1 Payne (US Navy)
    Offline

    MM1 Payne (US Navy) New Member

    Joined:
    Jan 9, 2010
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Florida.
    1. Open Wifi Settings
    2. Click "Add a Wifi Network"
    3. Enter the SSID and click the security Drop down.
    4. Select your security Method. (I selected 802.1x Enterprise. This is probably the only security option that presents you with the additional inputs needed.)
    5. After selecting that option the dialog will change and will include the following options:

    EAP Method
    Phase 2 Authentication
    CA Certificate
    Client Certificate
    Identity (i.e. network username)
    Anonymous Identity
    Wireless Password (i.e. your network password)

    For my network, I had to select PEAP, then MSCHAP for the Phase2 Auth. I left the certificates blank, since our Wifi does not require them. I then entered my domain username for the "Identity" field. I left "Anonymous Identity" blank and entered my network password under "Wireless Password". I was then able to connect successfully.

    Hope this helps!
  6. mzman
    Offline

    mzman New Member

    Joined:
    Jan 11, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    I believe I am having the same problem at my work and Uni wifi. iPod touch connects then I open safari to input my credentials, sometimes I get the certificate notice. But with the Droid it sees the network, then says it is out of range and will not ever display the login page on the browser.

    I will try out the above and report back.
    Last edited: Jan 11, 2010
  7. Guurzak
    Offline

    Guurzak New Member

    Joined:
    Jan 2, 2010
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    Your company is using a Cisco WLC wireless system. This system comes preinstalled with a self-signed certificate, but this certificate should never be used in a production environment. If the network needs secure https logins it should replace the built-in cert with either a commercial cert or one they issue from their own CA. But there's no reason to use any cert at all if they're just going to have you press "accept". Tell your IT staff that if they allow http access to the webauth page, they will lose nothing and make things easier for clients which reject self-signed certs. (The Droid is far from the only device which does this.)
  8. Canefan
    Offline

    Canefan New Member

    Joined:
    Dec 27, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    My workplace is a large metropolitan hospital. There is no way that they are going to change their setup because my phone can't connect. Is there no way around this? My old WinMo phone worked just fine, I can't believe the cutting edge Droid can't create an exception for an invalid cert.
  9. Canefan
    Offline

    Canefan New Member

    Joined:
    Dec 27, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the suggestion. Unfortunately the only way to get the phone to recognize the wifi router is to specify None for security. With the Enterprise selection, it says Out of Range. :icon_evil:
  10. XJBluto
    Offline

    XJBluto New Member

    Joined:
    Feb 4, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    WI Fi

    If we installed a commercial certificate on the Cisco Wireless Lan Controllers would issue be resovled ?

    Would the Droid accept the commercial cert with no problem?
  11. leggy
    Offline

    leggy New Member

    Joined:
    Aug 8, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    This thread looks old and not sure if problem was solved. I am having the same problem, can connect wo WiFi but can't access internet, I recieve a message of not being able to display page and that https://1.1.1.1./login.htm?redirect is not accessible.

    Is there any solution for this yet?

    By the way, my phone is Droid X with 2.1
Search tags for this page

accept website certificate ipad

,
android browser won't redirect
,

android wifi anonymous identity

,
android wifi identity
,
anonymous identity and password
,

anonymous identity wifi

,
anonymous identity wifi android
,
cisco is pleased to provide the wireless
,
cisco is pleased to provide the wireless lan infrastructure
,
no login pop up on wifi android
,

welcome to the cisco wireless network

,

what is anonymous identity in wifi

,
what is anonymous identity wifi
,

wifi anonymous identity

,
wifi identity android