Question about apps not appearing in the usage lists

Discussion in 'NextApp' started by Tabs, Sep 25, 2010.

  1. Tabs

    Tabs Member

    Joined:
    Dec 3, 2009
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hi guys,

    I've had SystemPanel (paid version) for a while now and I've noticed that apps that use a lot of battery/CPU (Google Maps/Navigation is the main one I'm thinking of) aren't actually appearing in the monitoring history. Why is this?

    Also, the apps listed don't seem to actually add up to my total battery use either, they're all mostly below 1% and don't add up to anything close to 100% of the usage.

    Can anyone clarify what's going on for me?

    Thanks!
    Ryan
     
  2. tliebeck

    tliebeck Member

    Joined:
    Feb 5, 2010
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hi Ryan,

    Sorry for the very long delay in response.

    What's being monitored is the CPU time of each application. The sum total of the CPU use over time should be very low, as if it were 100%, the battery would drain entirely within a mere couple of hours.

    Some apps will operate under a different process than you might expect. For example, LauncherPro will appear as the "Android Home" app or whatever your device-specific version of Android calls it.

    You may also see apps grouped into the "system processes" category. If you click on this item in the list of "Top Apps", you'll find that it shows a list of Linux processes and how much CPU each of these use. For example, the Android media player app won't use much in the way of CPU while you listen to music, but the item "mediaserver" under System Processes will use quite a bit. For navigation, you'll likely see something similar, I believe the "gps" process typically winds up reporting quite a bit of usage.
     
  3. Tabs

    Tabs Member

    Joined:
    Dec 3, 2009
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    And here's the late reply from me hehe:

    I just tried running the battery on my Droid way down from like 90 to 40 percent running Maps Naviation while monitoring with System Panel and I see nothing in the battery usage history that accounts for where all that battery went. Is there a setting or something that I'm missing?

    Ryan