Problems after trying to flash CM10.1 on XT907. Please help.

Discussion in 'Android Tech Support' started by rdubbs, Jun 12, 2013.

  1. rdubbs
    Offline

    rdubbs New Member

    Joined:
    Jun 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    First of all, thanks to everyone who contributes and shares knowledge on these forums; they are an invaluable resource. I am a first time poster and very inexperienced android user who tried unsuccessfully to flash CM10.1 on my XT907. I spent several days reading forum posts and watching you tube videos on the process, but still managed to eff it up somehow. Now, whenever I try to boot my phone, I get a black screen with the following text on it:

    AP Fastboot Flash Mode (S)
    10.9B(*) (sha-le9f557, 2013-03-22 09:18:22)
    eMMC Info: Size 8GB

    Device is LOCKED, Status Code: 0

    Battery OK

    Connect USB
    Data Cable

    Failed to hab check for boot: 0x56
    Fastboot Reason: Boot Failure

    I've tried booting to recovery and doing a factory reset, but I still get the same black screen and text after reboot. If anyone can offer any guidance, it would be GREATLY appreciated.

    I apologize for the long post, but I want to communicate in detail the steps I went through.

    1. rooted with motochopper and installed safe strap without any issues.
    2. downloaded Cyanogen Mod 10.1 (the exact zip file I used is : cm-10.1-20130518-UNOFFICIAL-xt907 from xda dev website and gapps package (file: gapps-jb-20130301-signed) to external SD
    3. In general, I followed the directions from this page:
    http://bestandroidstuffs.com/install-cyanogenmod-10-1-based-on-android-4-2-1-on-droid-razr-m.html
    4. Booted to recovery with safestrap> made TWRP back up of stock ROM > wiped cache, davlik cache, system and did factory reset
    5. Went to install zip from SD card > selected CM zip file > selected 2nd zip file, gapps > installed > rebooted > boots to the black screen with text on it (above)

    So far I've tried re-installing the CM10.1 zip file from the external SD in recovery and doing a factory reset (twice). I've even gone so far as to call verizon and geek squad. No matter what I do, the phone always boots to that black screen with the same text on it.
  2. crmcsh01
    Offline

    crmcsh01 New Member

    Joined:
    Jul 26, 2011
    Messages:
    39
    Likes Received:
    1
    Trophy Points:
    0
    I would flash it back to stock using rsdlite, then unlock your bootloader before you try to flash cm10.1. I am not sure if cm10.1 requires your bootloader to be unlocked but it will make your life much easier if it is.
  3. rdubbs
    Offline

    rdubbs New Member

    Joined:
    Jun 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, but I think I'll stick with stock, at least for the short term future I tried using RSDlite to flash AOS 4.1.2, which was the OS on the phone originally without any luck. I used the fast boot file for 4.1.2 from this site. RSD worked fine and my phone was recognized as an ADB device, but after uncompressing the file in RSD then pressing start, I get a "flash failure" message.

    Is it ok to flash the XT912 zip onto my XT907? As far as I know, they are almost the same phone. Otherwise, can anyone help me locate the right fast boot files. All the links to the xt907 fastboot files I've found are not working.
    Last edited: Jun 12, 2013
  4. Scimino
    Offline

    Scimino New Member

    Joined:
    Feb 28, 2012
    Messages:
    207
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Bradenton Florida
    Maybe just a bad zip. I would download again from another site.
    That zip is for the xt912 which is just a RAZR maxx or RAZR. I think that's your issue right there. They are different.
    Last edited: Jun 12, 2013
  5. rdubbs
    Offline

    rdubbs New Member

    Joined:
    Jun 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    THANK YOU ! Downloaded the XT907 zip and it worked like a charm. I've been stressed out over this for the last 2 days.
  6. Scimino
    Offline

    Scimino New Member

    Joined:
    Feb 28, 2012
    Messages:
    207
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Bradenton Florida
    Glad u could fix it. I think the only difference is the circle widget on the xt907.
  7. Rodgers
    Offline

    Rodgers New Member

    Joined:
    Aug 9, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Did you have to use your computer to regain boot up? I've done the same thing and can't get it back to normal. Please help!!!!!
  8. rdubbs
    Offline

    rdubbs New Member

    Joined:
    Jun 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0

    Yes I did have to use my computer. You need to download the RSD lite program and the XT907 fastboot files (both of which can be found online) to your computer. I used the instructions on this website as a guide. Good luck.
  9. nossing
    Offline

    nossing New Member

    Joined:
    Oct 22, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I got myself in the same jam... could you please tell me exactly where you got the right zip?

    Could you tell the exact steps you used, pretty please? I'm stressed out right now...
Search tags for this page

ap fastboot. cm10

,

cm-10.1 for xt907.zip

,

cm10.1 download for xt907

,
cm10.2 no service
,

failed to hab check for boot 0x56

,

failed to hab check for boot 0x56 fastboot reason flash fail

,

fastboot file for xt907

,
no service in xt907
,
rescue xt907
,

why fail flash xt907

,
xt gets black screen when booting custom rom through safestr
,

xt907 cm10.1

,
xt907 cyanogenmod gsm
,
xt907 did a factory reset and still have safestrap
,
xt907 safestrap black