1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Problem with gallery

Discussion in 'Android Tech Support' started by superkrai, Apr 18, 2010.

  1. superkrai
    Offline

    superkrai New Member

    Joined:
    Mar 13, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am running 2.1 on my droid and it is not rooted. I have 100 pics and 10 movies so far on my sd card.

    My gallery is not showing all the thumbnails or previews for more than half of my pics and 4 of my movies. There is a box in place of each file but no preview. If i click the box, it opens the pic or plays the movie.

    Any ideas?
  2. gonzan
    Offline

    gonzan New Member

    Joined:
    Apr 1, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I am having the same problem. Also I really need to be able to control the order that photos are displayed in each folder, as I need to use it to show my portfolio and client images in the proper order.
  3. 1linuxfreak
    Offline

    1linuxfreak New Member

    Joined:
    Nov 29, 2009
    Messages:
    437
    Likes Received:
    0
    Trophy Points:
    0
    I call it the mystery gallery, never know when and if the photo you take will show up or if so when, hence mystery.
    Sometimes icons on the home screen disappear when I come out the gallery or browser for several seconds as well.
  4. FLE
    Offline

    FLE New Member

    Joined:
    Feb 19, 2010
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Biloxi, MS
    Something similar happend to me when I did a factory reset on my phone. I did not do anything special to the phone and the movies now play. At first I was getting a error message saying invalid format. Is this what you are gettting?
  5. jenny
    Offline

    jenny New Member

    Joined:
    Apr 19, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Any idea what is going on? I am having problems with getting pics sent to me and I download them but they don't how up in gallery right away. Sometimes it shows up a few minutes later but most of the time it shows up a day or two. Is there a refersh or something? I'm getting annoying with this update.
  6. mbooty
    Offline

    mbooty New Member

    Joined:
    Dec 26, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Gallery bug

    The photo gallery -- besides being slow, jerky, overly complicated, and riddled with inconsistent user interface graphics -- is outright broken. If you take a pic with the camera, and then go look for it in the gallery, it will not be there. You can take 4 or 5 pics and they will not be in the gallery. Take the battery out, reboot the phone, and magically, there are the pics! How does crap like this make it past Motorola QA and testing? I mean seriously, did anyone at Moto even try the gallery out before shipping the code?
  7. MarkB
    Offline

    MarkB New Member

    Joined:
    Nov 11, 2009
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gulf Coast of Florida
    I'm having the same problem with the gallery, but only with pictures taken with the Pro Zoom Camera 5x app. I get the blank frame in the gallery. If I click on that frame, the phone tries to load it and then the screen goes dark. If I go directly to the file through astro file manager and tell it to view the jpg with astro viewer, it tells me invalid format. Email that same file to my PC and it displays fine.

    Pics taken with the stock app show up fine in the gallery.
  8. mbooty
    Offline

    mbooty New Member

    Joined:
    Dec 26, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    >> If I click on that frame, the phone tries to load it and then the screen goes dark.

    Yes, I have that version of the problem as well. Sometimes when I try to view a recently taken photo, it just displays a black picture.

    Poking around on the net and various forums, this bug and related bugs all seem to be related to how the "Media Scanner" process updates file info in the background. I have no idea why, but it seems that it can take seconds to minutes to even hours to update the contents of the gallery. Any app trying to access the non-updated file structure will run into problems. How/why this problem got introduced, who knows. Makes me frustrated though every time I go to use my camera, because the photos cannot be accessed to email or SMS them.
  9. MarkB
    Offline

    MarkB New Member

    Joined:
    Nov 11, 2009
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gulf Coast of Florida
    Thanks for the research mbooty.

    Heck, they can't even be accessed to VIEW them. How stupid is that? "Yes folks, I just took pictures of our little get together with my 5MP phone camera. No you can't see them now."
  10. mbooty
    Offline

    mbooty New Member

    Joined:
    Dec 26, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Agreed, it is a supremely frustrating set of bugs. Time and date on photos are wrong, photos sometimes show up as black images, images not showing up at all in the gallery.

    Adding to the frustration, at least for me personally, are the following:

    1. People who say "It's not supposed to be a real camera, it is just a phone." Well, right, but if it has a camera on it that I presumably paid for, I would like to at least be able to see the photos I just took.

    2. That Google outsourced the "improved" gallery to Cooliris, a developer who seems to not have such a great reputation.

    3. The Google apologists on the forums who seem to think that all these problems are "no big deal".
  11. rawveeda
    Offline

    rawveeda New Member

    Joined:
    Nov 22, 2009
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    0
    temporary solution?

    after I take a picture (or several), I noticed if I press the thumbnail in the upper right corner of the camera app then press done,
    hit home, then go to the gallery... my recently taken pics show up.
    If I just take the pic -then go to the gallery they don't show.
    That is my little finding & temporary solution.
  12. mbooty
    Offline

    mbooty New Member

    Joined:
    Dec 26, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Hi, thanks for the tip. I have found the same thing. The problem is, that you have to do that in between *every* pic you take. If you take 2 or 3 pics in a row, then only the last one you took will show up. AND... that is only sometimes. If you email or SMS the pic from within the camera app using the "share" button, then the pic will -- based on my experience -- not show up in the gallery unless you take out the battery and reboot the phone.
  13. cardiacjunkie
    Offline

    cardiacjunkie New Member

    Joined:
    Dec 25, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Since update I keep getting this message when trying to open gallery to view. "The application gallery process.com.cooliris.media has stopped unexpectedly. Please try again." Well, I've pulled battery and still will not let me view what's on the phone. I really would prefer not to do factory reset and loose all my apps/settings for them.

    Also, since update, the sound setting for missed call is barely audible. You have the one tone that alerts you that you have a text but then when switches to missed call app the sound is hardly noticeable.
    :icon_ nono2:
  14. Davy12
    Offline

    Davy12 New Member

    Joined:
    Nov 19, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Ventura California
    I had the same problem with empty frames showing up in the thumbnail portion of the gallery. I decided to take a look around and mounted the SD card and looked in the thumbnail folder using my PC. everything looked fine so I unmounted and disconnected my Droid. When I went in to look at the gallery with my Droid all the thumbnails were there. Hope this works for you.
  15. Zippster
    Offline

    Zippster New Member

    Joined:
    Oct 28, 2009
    Messages:
    523
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Buffalo NY
    Man the more I look around the more things I have to complain about since 2.1, same thing here that you all posted already, plus anyone having their SD card disappear? Had it tell me several times that I couldnt use the camera because I didnt have one? Reboot fixes it but I am going from a rock solid phone I loved before the update to a buggy POS.
  16. MarkB
    Offline

    MarkB New Member

    Joined:
    Nov 11, 2009
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gulf Coast of Florida
    Thanks Davy, but that shouldn't be necessary - and certainly not each time you take a picture!
  17. petehunter
    Offline

    petehunter New Member

    Joined:
    Apr 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    After I downloaded the gallery revision the app icon on my desktop no longer works. I get an error message that says "the. application is no longer installed on your phone". This is stupid! Gallery CAME with the phone when I bought it and I put it on my desktop. I can usually get it to work if I turn the camera on and then select gallery, but that is dumb. It starts the camera app when I do not want it started. What gives?
  18. MarkB
    Offline

    MarkB New Member

    Joined:
    Nov 11, 2009
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gulf Coast of Florida
    That's been covered a zillion times. The shortcut on your desktop is to the OLD gallery app which has been uninstalled. Just delete that shortcut and drag a new one to your desktop from your app drawer.
  19. petehunter
    Offline

    petehunter New Member

    Joined:
    Apr 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
  20. MarkB
    Offline

    MarkB New Member

    Joined:
    Nov 11, 2009
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gulf Coast of Florida
    And I apologize if my reply came off as snotty. It wasn't meant that way. Generally though, it's a good idea to use the forum search if you'd like to find quick answers, in case anyone has encountered the same problems before. Like a search on "gallery icon 2.1" would come up with threads discussing this.
Search tags for this page
android gallery black thumbnails problem
,
android gallery jpg black
,

android phone picture error thumbnail

,
android photo gallery error
,
android+photo+gallery error
,
droid camera invalid image
,
droid makes.pic dark.when select to view
,
galerie coliris media x2
,
gallery bug
,
google images black picture problem
,
jpg pics no properties droid
,
my pic previews wwont show up on my s3
,

processocom cooliris media

,
when i click on my gallery in droid it says no storage where
,

when pictures in android gallery says invalid file