Possible fix for home apps always redrawing desktops...

Discussion in 'LithiumMod' started by Isaiah, Jul 21, 2010.

  1. Isaiah
    Offline

    Isaiah New Member

    Joined:
    Jan 10, 2010
    Messages:
    407
    Likes Received:
    0
    Trophy Points:
    0
    So, I know I'm not the only person who had this problem, because I read at least one other person complaining about it.

    if more of you have this problem, where the home app redraws the desktop when an app (assuming the phone hasn't been used in another orientation, it redraws every time you switch orientation). then the fix (at least for me) is very simple.

    I thought it was a memory issue so i killed as many memory sucking apps as i could and removed most of my widgets -- didn't fix it... Yesterday I was tooling around with spare parts and lowered the speeds (from fast to like... medium?) of window transitions and some other window-speed related thing (don't have my phone infront of me to find names)

    now I can go in and out of apps without waiting for the home app to redraw everything. I'm using launcher pro, but I assume since Ive heard of people using the stock launcher and helix launcher having the same problem, the fix might be the same too.


    hope this was at all useful. If not sorry for wasting your time :p
  2. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    I'm trying out UD at the moment but still having some redraw issues with ADW launcher so I am trying this out. Will post again once I've had some time to see if it works.
  3. stark23x
    Offline

    stark23x New Member

    Joined:
    Mar 7, 2010
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    0
    Huh. Who'd a'thunk that? I turned both Window Animations and Transitions to "Normal" and the redraws stopped.

    Interesting. I guess speeding up the transition times moves too fast for the graphics engine to keep up? I know jack squat about code, so I'm just guessing here.
  4. sparty569
    Offline

    sparty569 New Member

    Joined:
    Mar 13, 2010
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Metro Detroit
    Both of those settings have been set to Normal for me, and I still occasionally get screen redraws.
  5. Isaiah
    Offline

    Isaiah New Member

    Joined:
    Jan 10, 2010
    Messages:
    407
    Likes Received:
    0
    Trophy Points:
    0
    for anybody interested in an update; i set the Spare parts settings from high-> normal-> none and now its really just amazing... those features seemed to bog the launcher down a lot. home screen transitions are faster, redraws are more rare and seemingly a bit faster as well.

    also i dropped fancy input animations, because loading the keyboard seemed buggy and slower lately... I haven't checked to see if thats fixed yet, but heres hopin'


    really glad to hear its helped you guys too
  6. jmayer
    Offline

    jmayer New Member

    Joined:
    Jul 9, 2010
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    it seems to speed things up a bit but i still get slow redraws when the homescreen rotates. i really wish there was a way to turn that off - i really dont need landscape homescreens
  7. Isaiah
    Offline

    Isaiah New Member

    Joined:
    Jan 10, 2010
    Messages:
    407
    Likes Received:
    0
    Trophy Points:
    0
    you can... I've got it disabled unless the keyboard is out. go into settings and disable auto rotation, or do it in your home app (which is what I did, so everything else still rotates)
  8. andrew149
    Offline

    andrew149 New Member

    Joined:
    Jul 16, 2010
    Messages:
    269
    Likes Received:
    0
    Trophy Points:
    0
    turned off transitions wow no lag
  9. actngrezy
    Offline

    actngrezy New Member Developer

    Joined:
    Mar 21, 2010
    Messages:
    1,074
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    delaware
    Awesome find. Been trying to get a redraw for past 2 hours and havent had one yet. Also I'm using launcher pro and turned the speed up in the launcher pro settings to also the fastest speeds like in the " opening speed " and "minimum scrolling speed" so the transitions between screens are still def fast.
  10. jmayer
    Offline

    jmayer New Member

    Joined:
    Jul 9, 2010
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    i'm just using droidx kangerade - no additional home app. and rotation for websites and such would still be useful and i think disabling that setting turns all of that off. why was homescreen rotation added anyway, i see no benefit?

    is there any way to just disable it for homescreens without adding an entire home app?
  11. Isaiah
    Offline

    Isaiah New Member

    Joined:
    Jan 10, 2010
    Messages:
    407
    Likes Received:
    0
    Trophy Points:
    0
    I don't recall at all what the default homescreen launcher for kangerade is. I've just been using my launcherpro... which for speed is what I would recommend for you. I've got a feeling you are probably using ADW or like "launcher1"or"2" either way there if you hit the menu button while on the homescreen there should be an option along the lines of "preferences" that'll let you tweak those settings...

    If not really, just do launcherpro, simple, fast, easy.
  12. listenman20
    Online

    listenman20 Member

    Joined:
    Dec 29, 2009
    Messages:
    858
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    GA
    Try going to setting>display> uncheck auto rotate
  13. Isaiah
    Offline

    Isaiah New Member

    Joined:
    Jan 10, 2010
    Messages:
    407
    Likes Received:
    0
    Trophy Points:
    0
    that may be what i did... i should really just get my phone and see... but lazy


    Won't that disable it across the phone, instead of just the home?
  14. longrifle325
    Offline

    longrifle325 New Member

    Joined:
    Apr 27, 2010
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lorain, OH
    if you just want to disable "home" auto rotation and not for viewing apps and internet and your using launcher pro

    settings>behavior settings> un check auto rotation

    this is my setup..i dont get the landscape view on home unless i slide the keyboard but in an app it will rotate!:icon_ banana:

    if you go to droid setting>display> uncheck auto rotate (this will disable auto rotate for all apps unless keyboard is out) not what i wanted!
  15. gloster
    Offline

    gloster New Member

    Joined:
    Nov 17, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    You may like the widget from the application "AutoRotate OnOff" by CurveFish. It gives you a simple on/off widget for autorotate.

    Typically, I like autorotate off, but in some applications I need it. So I have this widget on my homescreen and I flip the switch before starting an app that needs rotation.
Search tags for this page

redrawing apps constantly