1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

PLEASE HELP...issues after unrooting!!!

Discussion in 'Android Hacks and Help' started by jbg25, Jan 19, 2010.

  1. jbg25
    Offline

    jbg25 New Member

    Joined:
    Jan 1, 2010
    Messages:
    560
    Likes Received:
    0
    Trophy Points:
    0
    Hey guys...sorry this is going to be so long...but I think the more info I give you the more likely you will be able to identify my problem and help me fix it.

    A little backstory.....
    A few weeks ago I was trying to get help unrooting my droid. I was having problems with the rom that I loaded (following these instructions....http://androidforums.com/how-tips/29204-how-root-install-droid-2-1-a.html).

    This was several weeks ago, and I had used droidroot helper v4 and at the time the OP had posted the files including tar to drop in the nandroid backup folder that gave me HCs old 2.1 rom w/o su. It was very buggy for me and I wanted to uninstall/swap with another rom. But no matter what i tried (found many instructions using SPR, adb, shell or a combo of the three) I kept getting errors along the way that prevented me from doing anything.

    Then I found Speedymons uninstall instructions on alldroid.org. But I got errors every time I tried to restore to the virginoem file. The error I kept getting was... "status 25".

    So I PM'd SirPsycho and developer of Droidroot helper over at alldroid.org, but never heard back. I have since found out the site was hacked...so I waited almost 2 weeks, then posted this issue over there...but although a had 2 dozen people read...no one had any thoughts.


    back to the isse at hand....
    So I had to go elsewhere and hope someone could help me unroot. At the suggestion of the person who posted the rooting method...I tried doing it through downloading the Eclair_2.0.1 file and renaming to udate.zip and dropped on SD card to install, and got more errors. This time the errors were..

    Assert failed: apply_patch_check("/system/app/alarmClock.apk", "36fa8c6f8036e4bed36056c1797c4ee40f746b3c","face49 02c83611a0e55c8640dc95133ebe2c5fla")
    E:Error in /sdcard/update.zip
    (status 7)
    Installation aborted.

    So, I spent a few hours doing a lot of reading and experimenting with adb and shell...and finally got back to oem...BUT I AM POSITIVE I LEFT SOMETHING OUT AND FEAR IT WILL CAUSE PROBLEMS!

    The following quote is from my post in the tread posted above that describes how I did it.


    Here is the issue, I have had some bugs now that I never experienced before. Random call outs, random shutoffs that require me to pull the battery to restart, more f/c's than I rememeber with the unfinished HC2.1 rom or the oem 2.0.1 before I started adding roms.

    So I read that I could reinstal the 2.0.1 update manually which would clear any potential issues hidning in the OS, using the original 2.0.1 update posted on sholes.info. But I still get erros and the install aborts...and am VERY VERY afraid this will prevent the 2.1 update whenever it does go out.

    If anyone is still reading this...first THANK YOU...second any idea what I have done or what I can do to fix?

    Thanks!!!!
  2. Bear in NM
    Offline

    Bear in NM Active Member

    Joined:
    Nov 12, 2009
    Messages:
    1,389
    Likes Received:
    1
    Trophy Points:
    38
    Not sure if this is a solution you could apply, but it appears that some Verizon Stores have the ability to reflash the phone. I normally would not suggest to someone who has "played" with their phone to run to VZW for a fix, but as you phone is not bricked perhaps they could reset you correctly. If it were me, I would find a store that has the ability. If they press for a reason, explain that you added some programs that may be causing some issues, and offer to pay for their time.

    This is just a wag, but if someone here finds a solution, and your phone appears to be running correctly, I am betting in the back of your mind your gonna still be wondering? If so, see my first paragraph. And as you now only have the factory recovery, about the only thing you could try is perhaps downloading a different stock 2.0.1 to confirm that you do not have a bad file, but I guess is that you do not. I would not get too wild and crazy at this point, as you still have a working phone.

    From you error message it would appear that the 2.0.1 you are trying to apply is indeed finding a file mismatch and aborting. I don't know if this is just a normal error trying to install 2.0.1 over 2.0.1 when it expects 2.0 or what. The other thing right now is that we do not know whether the 2.1 is gonna have problems with all of the phones like your's that have been unrooted. Perhaps no problem. One thing for certain is that once 2.1 comes out, this place is gonna be busy if there are any problems. I would just not accept any 2.1 ota's, and check back here to see how things are going once 2.1 is out.

    Craig

    Edit:

    Check out this thread or over at Alldroid. Looks like a maintenance relaease of 2.0.1 may be out and this may clarify your situation. One person reported it broke his root, which could mean good news for you.
    http://www.droidforums.net/forum/droid-general-discussions/16618-droid-update-morning.html
  3. forkup
    Offline

    forkup New Member

    Joined:
    Oct 31, 2009
    Messages:
    317
    Likes Received:
    0
    Trophy Points:
    0
  4. jbg25
    Offline

    jbg25 New Member

    Joined:
    Jan 1, 2010
    Messages:
    560
    Likes Received:
    0
    Trophy Points:
    0
    I have a thread over on alldroid where I have been getting some help...now things are worse. before when I had recovery I tried to load the virgin oem....but kept getting errors.

    Having tired that and failed I re rooted my phone in an attempt to get SPR back to load a virgin backup a different way.

    Now the issue is in forcing the phone out of root and back to stock last time I must have unintentionally changed something I was not supposed to. I have no reboot recovery at all. I can boot the phone to use it...I can mount it to my PC...I can even issue commands in ADB and in shell.

    Now every time I try to boot into recovery...I get the moto logo.
Search tags for this page

virgin oem