Photo Gallery error

Discussion in 'Droid X Tech Support' started by nacho220, Jul 11, 2011.

  1. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have been having trouble with my photo gallery on my Droid X for quite some time now. It doesn't bother me too much I suppose. Well at least up until I found a bit more wrong with it.

    For a number of months when I went to the "gallery" it would hesitate for a second, then load up but go right back to the home screen as if it force closed itself. Sometimes I was able to get it to stay there but only then would it show photos for "this week" as opposed to all of the other photos / folders / tags I had. Then last week I was finally able to get into it and I went through the photos and deleted a bunch of them I've been wanting to delete...thinking maybe I need to delete some of them for this issue to stop happening. I have a little over 1,000 photos on there...enough space still yet though. I deleted maybe 400...selected them all, hit delete and ok great. But wait. They are still there. I tried to go and do them each individually and when I click on the menu button the delete option is faded out, not allowing me to delete any of these photos. So, that leads me to believe something else is wrong if it is showing me these photos but not letting me delete them.

    Anyone else have this issue? Suggestions? I don't mind deleting them all at this point if it were to help, but obviously that isn't possible.

    Appreciate the help in advance!
     
  2. LorriJones

    LorriJones New Member

    Joined:
    Jul 11, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've had my DX since may and I have the same problem. I hate that I cannot upload photos online!!! Help!!

    Sent from my DROIDX using DroidForums
     
  3. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I use Photobucket and have the Photobucket app installed and it uploads my photos as I take them...that works fine. But its good to know that someone else is having the same problem...at least so that maybe there is a fix out there.
     
  4. sabroso

    sabroso New Member

    Joined:
    Jan 15, 2011
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico City
    Ratings:
    +0
    old Fixed!

    This is an old Issue since Froyo in Droids,
    The problem is a "Empty" folder that is corrupted (I don't know the tecnical details why was that folder created).
    You need to install FREE "Gallery 3D" from the market
    https://market.android.com/details?id=com.cooliris.media
    and from that app erase that "EMPTY" folder an voíla the normal "Gallery" don't FC anymore.
    Anyway after I have used that new "Gallery 3D" I keep using it up today.

    Best Regards Sa6r0s0 :greendroid:
     
  5. ras0787

    ras0787 Member

    Joined:
    Aug 10, 2010
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I had this happen to me to a while back. For me it was a corrupt folder. Also in my case the Gallery 3D app did the same thing when I downloaded it (although this worked for some people). What I did to fix the issue was pull my photos off my sd card, put them on the computer, and go through them until I found the culprit. I knew which pic was causing the problem because when I opened it the image viewer said something along the lines of "cannot open this file." Deleted it, put everything back on my sd card and my gallery was working again. Happy photo/folder hunting!
     
  6. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Thanks for this info guys. Cheers! I will try these fixes and report back to see if they worked. Appreciate it again..very helpful!
     
  7. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I DL the 3D Gallery app and was not able to fix it through there. As I looked in each folder (which somehow folders were made with date ranges that weren't listed as such in the original gallery)...as I looked into each of the folders each photo changed to a more recent photo I had taken. So I just kept scrolling and it kept going eternally with a duplicate of that recent photo.

    I took the SD card out and put it into my computer but now on the SD Card I cannot find any of the photos from my phone. However they are there on the SD card somewhere at least...because I try to get into both the stock gallery app and 3D gallery and it tells me to insert the SD card.

    So.... its clear now something is messed up. Any ideas now?

    Thanks in advance!
     
  8. ras0787

    ras0787 Member

    Joined:
    Aug 10, 2010
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I usually just plug my phone into my computer and it reads the SD card that way. Its easier then taking the thing out lol. Anyway to get to your pics go to the folder called DCIM then go to the Camera Folder. If you have pictures in there you downloaded they will be in the downloads folder spread around randomly. Apps also generate pics sometimes which could also be the cause, so if you can't find it the first time around search some of the app folders for pictures that may be corrupt.
     
  9. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Is there any way to tell that the picture is corrupt? I deleted all of the photos and thumbnails from the SD card and put it back in the phone. The regular gallery works I guess in that it says that there are no photos...so at least it isn't force closing on me. However I opened up the 3D Gallery app and it still says there is a folder with over 1,000 pictures in it, despite the fact that I deleted them all. And the photo is that same one that was duplicated over and over again like I explained above. I guess maybe that photo is/was the corrupt one...however that photo was taken a long time after this problem started occuring... so, I dunno?

    I uninstalled the 3D Gallery app and reinstalled and it still says
    (1156)
    US

    when I open the app...but now there is no photo. I tried deleting a number of photos found in the different app folders too.

    I guess maybe I need to know what I am looking for in the corrupt file/photo?

    Thanks again in advance.
     
  10. kevinkar

    kevinkar Member

    Joined:
    Sep 23, 2010
    Messages:
    300
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Does that app scan the entire phone and report ALL image files including app icons and other images? If so, that's probably the reason you see so many images. You definitely don't want to delete them all and probably can't for system images unless you have root access to those folders.
     
  11. steve42day

    steve42day New Member

    Joined:
    Nov 8, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Rather than search for corrupt files, try the insytructions below.

    BTW, I can’t take credit for this; I got it from Sailmaker on Android Central forum in a post dated Oct 2010.

    Go to:
    Settings >> Applications >> Manage Applications >> All tab
    For each of the following, I clicked on Clear data and Clear cache: (Just clearing Gallery did not do it for me)
    Gallery
    Media Container Service
    Media Storage
    Then I restarted phone by holding down power button, clicking Power Off, then held it again to turn on and working great! It did take a few minutes for the Gallery to get all the thumbnails again the first time I started it, but works!
    I was afraid I deleted all files on SD but they are all still there. Just be patient, will take several minutes for Gallery to repopulate.

    Worked for me. Good Luck
     
  12. nacho220

    nacho220 Member

    Joined:
    Jul 19, 2010
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    @steve42day

    Thanks for the suggestion. I did try it but it didn't seem to work. The gallery seems to work fine for maybe 30 pictures or so, then all of a sudden the gallery will show no photos, however the photos are still on the SD card. The initial issue that it flashes back to the home screen and won't even let me in the gallery doesn't seem to happen anymore...just this what seems to be related issue. Again, this was after I tried your suggestion Steve. I can't seem to find any other corrupt files, but I guess I could keep looking as it seems that might be the lingering issue.
     
Search tags for this page
android error displaying media
,
android gallery error displaying media
,
atrix 2 error displaying media
,
droid 3 error displaying media
,
droid error displaying media
,
droid x2 error displaying media
,

error displaying media

,

error displaying media android

,
error displaying media droid
,
error displaying media droid x2