1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

phone numbers from facebook

Discussion in 'Android Tech Support' started by onyxstar33332006, Apr 24, 2011.

  1. onyxstar33332006
    Offline

    onyxstar33332006 New Member

    Joined:
    Jan 3, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    i have the facebook app for my phone (droid 2). for some reason tho, anyone who has their phone number on facebook that is in my contact list has a +1 before the number. so if they text me and i try to reply to the text it says message fails b/c of the +1. i've tried unlinking and relinking the profiles but it doesn't solve the problem. it also is locked and won't let me edit the number for the +1. does anyone else have this problem? if so, how did you resolve it...if possible. and if there is no way to get rid of the fb number...is there a way to make the other contact number a default number rather than using the fb number? thanx!!
  2. Sethhhh
    Offline

    Sethhhh New Member

    Joined:
    Mar 5, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Yeah im having the same problem, I unlinked and relinked as well and even if you long hold the other number it will allow you to select make default number, yet I still can't text the person. If someone could please help id appreciate it

    Sent from my DROIDX using DroidForums
  3. Backnblack
    Offline

    Backnblack Premium Member Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    11,263
    Likes Received:
    5
    Trophy Points:
    0
    Facebook is at fault......Only thing you can do IIRC is to not use the built in social app.
  4. Sethhhh
    Offline

    Sethhhh New Member

    Joined:
    Mar 5, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Ok so I've been messing around with it trying to fix this problem, and I found a way I think. What I did was go into your contacts to the one you are having problems with (like every one from facebook) add a new number, select mobile first then enter the number, then long hold after you save it and select make default number. Then when texting select the number that doesnt have the +1 it should work fine, atleast it has for me so far

    Sent from my DROIDX using DroidForums
  5. Backnblack
    Offline

    Backnblack Premium Member Premium Member

    Joined:
    Nov 18, 2009
    Messages:
    11,263
    Likes Received:
    5
    Trophy Points:
    0
    So what do you do if you have hundreds of contacts?
  6. Sethhhh
    Offline

    Sethhhh New Member

    Joined:
    Mar 5, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Haha yeah I have the same problem, so ive just been doing it as someone texts me or I need to text someone, no need in changing them all if you dont talk to them

    Sent from my DROIDX using DroidForums
  7. bdcovington
    Offline

    bdcovington New Member

    Joined:
    Jul 29, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I have a fix for this issue, it works, but its annoying as hell. The best answer would be for everyone to petition facebook to cut it out already, but thats not likely to happen, so here it goes.

    Step 1. Go to a contact that is having an issue (a contact where the +1 is appearing before your phone number.)

    step 2. Edit the contact (note: you have to have created an actual contact to do this, a contact that is only imported from facebook without a card on your phone is not going to be able to be editted)

    step 3. Create a new phone number (using whatever their phone number is) and code it as a home#, not mobile. save and exit edit mode.

    step 4. You should now see the home # there without the +1. Long click the home # and set it as the primary #.

    Step 5. Edit the contact again, and switch the home setting to mobile. Delete any other contact #'s in the card that you don't need (ex: #'s linked from google). Save and exit edit mode.

    Step 6. This should have fixed the problem, given you a new primary # without the +1, and given you the ability to text to that # without a problem because it is now coded as a mobile #. This fix was tested on an HTC Thunderbolt on the Verizon network. I'm going to assume it will work somewhat similar on other devices. I hope this helps.

    EDIT: This process, as far as my contacts are concerned, has not only given me a # i can actually text to, without the +1, but if done this way, has actually removed the # with +1 from the contact card entirely.
    Last edited: Jul 29, 2011
Search tags for this page
add phone number to facebook contact droid
,
android get phone numbers from facebook
,
facebook adds 1 to phone number text
,
facebook with phone number 1 403-992-9432
,
get phone numbers android facebook
,
how to find save contact number on fb
,
how to get numbers from facebook to droid x
,
how to get phone numbers off face book
,

how to get phone numbers off facebook

,
how to save facebook contact no in my android
,
how to save facebook numbers to droid
,
how to save fb numbers to your phone
,
it doesnt let me delete my phone number on facebook
,
save facebook phone numbers android
,
save facebook phone numbers to droid 4