Phone not switching to 4G lte internet when out of the house?

Discussion in 'Android Tech Support' started by King Bengals, May 9, 2017.

  1. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    VZ MOTO-7 Android 7.0

    This is an annoying problem I've noticed. Every time I leave work or the house & loose wifi connection with my main internet provider my phone doesn't seem to automatically switch from wifi to 4G Lte. I have to manually go into setting & turn off wifi to use internet when I'm on the move. The other issue is I can forget to turn it back on when I'm home since I don't notice I'm on the web using data from my cell service until I turn wifi back on. This has to be an issue with setting or the phone because I've never had a phone not senselessly switch off of wifi to cell service to get on the internet. What am I doing wrong?
     
  2. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,646
    Likes Received:
    6,751
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,254
    Current Phone Model:
    Moto Droid Z Force
    My Moto Z Force and my wife's Moto ZPlay both switch from WiFi to 4G smoothly and instantly when we leave the house. And then switch back to WiFi automatically when we return home. It may be an app interfering with the process? We had issues once with a postage app that completely took over the WiFi Settings and would not let her manually control WiFi at all. You could try putting your phone in Safe Mode and test the same process. When in Safe Mode Play Store apps don't run, only apps that came pre-installed on the phone run and is a troubleshooting tool to help see if a Play Store app is causing issues. To enable Safe Mode tap the power button like you are shutting down, then long press the Power Off option and you will see the Safe Mode prompt. To exit Safe Mode turn off the phone and turn it back on. The only drawback to running in Safe Mode is afterward some Play Store apps that require a password will prompt you to re-enter your password for that app / that account.
     
    • Like Like x 2
  3. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    Cool I will check that out. Those instructions sound familiar. I think I musta had something similar happen because those safe mode instructions ring a bell. I bet its something to do with iHeart or Pandora. Those apps seem to have a mind of their own. I've had both launch seemingly by themselves. So if I do the Safe Mode steps & the phone switches from wifi to 4G no problem then that means its a Play Store app causing the trouble correct? If that is the case how do I determine the guilty app, process of elimination? Thanks!
     
  4. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,646
    Likes Received:
    6,751
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,254
    Current Phone Model:
    Moto Droid Z Force
    If the issue does not occur in Safe Mode then it's not 100% definitive that it's a Play Store app, but does help to indicate that is the cause. Then the tricky part becomes which app to uninstall. I usually start with one or two at a time that were most recently installed. Then reboot and see if the issue is resolved. If not, uninstall one or two more and reboot and re test, etc. Sometimes just uninstalling an app and re-installing it resolves the problem. Sometimes the app is just not compatible until it's updated by the developers.

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1
  5. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    I think I figured out the problem. I noticed that when I left my home & started to walk down the street I would lose my home wifi connection & the phone was automatically connecting to a stored wifi network that was unsecured. I think it was trying or thought it was successfully connected to a wifi access point but the access point had no internet service. I see a huge list of available wifi access points on my phone. Some look like old ones from past locations like when I was in Philly & Cincinnati. I think the system sorta bookmarks these old networks. I seemed to have fixed the problem by going into the list when I was out of my home wifi range & selected the first 2 or 3 unsecured wifi signals & selected "Forget". Now it doesn't see those options & gets on the 4G network like it should. I'm going to test that list of wifi options by going to a remote location where I know there is no wifi available & see if that list goes to zero or if the phone is storing old wifi network names like "cookies" on your browser. In any case its working now. :)
     
    • Like Like x 3
  6. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,470
    Likes Received:
    7,049
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,391
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I always turn my wifi off when leaving my house and back on when I get home. I had it automated at one point, but it's such a habit for me for basically the reason you mention. I don't want it connecting to networks I don't know or trust or to ones that I use on rare occasions, but don't want to be connected to for an extended time.
     
    • Like Like x 1
Search tags for this page

phone not switching to lte from wifi android