Phone not switching from WiFi to 4G

Discussion in 'Samsung Galaxy S6, S6 Edge and S6 Edge Plus' started by Sajo, Jan 1, 2016.

  1. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,322
    Likes Received:
    6,587
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,085
    Current Phone Model:
    Moto Droid Z Force
    I have some friends over for New Years Day food and football. She just bought a Galaxy S6 (nice phone by the way). She uses WiFi all the time at home, no issues there. Her phone is not switching from WiFi back to 4G when she leaves her house. She has to reboot every time for the phone to start a 4G data connection. It's on 5.1.1. Any ideas?
     
  2. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,692
    Likes Received:
    3,549
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,037
    Current Phone Model:
    iPhone 7 Plus JB
    Try logging on to your wifi and see if it switches to 4G. Is this new or has it been happening from day 1?
     
  3. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,322
    Likes Received:
    6,587
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,085
    Current Phone Model:
    Moto Droid Z Force
    I will try to find out if its been happening from day 2 or just started recently. I wasn't sure if this was an issue with many Sammy phones or not
     
  4. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,692
    Likes Received:
    3,549
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,037
    Current Phone Model:
    iPhone 7 Plus JB
    What I meant was... see if your friends phone switches to 4g after leaving your wifi network...
     
  5. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,322
    Likes Received:
    6,587
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,085
    Current Phone Model:
    Moto Droid Z Force
    Thanks Jeffrey. Did some searching and found the Setting for Smart Network Switching. It was set to OFF. We turned it ON, and will see if that helps.
     
    • Like Like x 2
  6. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,692
    Likes Received:
    3,549
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,037
    Current Phone Model:
    iPhone 7 Plus JB
    Sounds like a plan..
     
  7. IIGood

    IIGood Silver Member

    Joined:
    Jul 13, 2010
    Messages:
    693
    Likes Received:
    242
    Trophy Points:
    143
    Location:
    Arnold, MD
    Ratings:
    +272
    Current Phone Model:
    Galaxy S6
    I've been having the same problem intermittently; I'll give the Smart Network Switching a try now. Did not know about that setting. Though kinda have to wonder why that's an option...why not do it automatically?

    Thanks!
     
    #7 IIGood, Jan 3, 2016
    Last edited: Jan 3, 2016
  8. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,322
    Likes Received:
    6,587
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,085
    Current Phone Model:
    Moto Droid Z Force
    To my understanding, Android is supposed to switch from WiFi to cell data (3G / 4G) automatically as soon as you leave that WiFi connection. The more I have been reading about this, I don't think that Setting is the fix. It seems like the same thing as the Moto Setting for "Avoid Poor WiFi Connections" and probably will have no impact on this issue? From all the posts I have found on other forums, many folks reported this on GS5's, GS6's and Note 4's after the Lollipop update; and a FDR seems to be the common fix. But maybe not? Knowing my friends and how they already hate OS updates (they have the "it works good right now...the way I bought it...why should I update anything" attitude) they will not do a FDR and just keep rebooting the phone every morning when she leaves home and leaves the WiFi signal; that forces the phone to connect to 4G for her. More reading and research when I have time.
     
  9. jackiescivic

    jackiescivic Diamond Member

    Joined:
    Feb 10, 2011
    Messages:
    1,676
    Likes Received:
    870
    Trophy Points:
    1,328
    Location:
    Germantown, WI
    Ratings:
    +951
    Out of curiosity, has she tried just turning off/on the mobile data instead of a full power cycle? I have no issues with the switch from wifi to 4g on my s6 edge.

    Sent from my SM-G925V using Tapatalk
     
    • Like Like x 1
  10. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,322
    Likes Received:
    6,587
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,085
    Current Phone Model:
    Moto Droid Z Force
    I forgot to ask that, I will mention that when I talk to them again. I did mention that toggling Airplane Mode On then Off again should do the same thing and force the 4G connection, and is faster than a reboot.
     
  11. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,692
    Likes Received:
    3,549
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,037
    Current Phone Model:
    iPhone 7 Plus JB
    As soon as the phone is out of wifi range, it should seamlessly connect to 3G, 4G.. whichever is available.

    If this is not happening, the radio could be defective. I would exchange the phone while you can..
     
  12. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,468
    Likes Received:
    7,038
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,379
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    While the Smart Network Switching option is more to get you the best connection possible, it should, in theory help. If the wifi signal is weak or the internet connection behind the wifi signal is slow, it should automatically switch to mobile data. You would think that being out of range would trigger the weak signal situation, but no guarantees there.

    Aside from toggling mobile data, how about toggling wifi as well? For years now, I've had a quick toggle or widget for wifi. When I leave a trusted wifi network, I turn my wifi off. Though I ran tests a long time ago and verified that android is actually really smart about conserving battery while still periodically scanning for a wifi network, I don't want to take a chance that my phone will connect to a network that I don't trust and I figure it has to be saving a tiny amount of battery life by not polling for open networks as I move around town. Just my own personal policy, but I'm wondering if toggling wifi off will force it to use mobile data instead. I'd think either one (wifi or data) should work, since it should poll for connections either way.
     
Search tags for this page

moto z force droid messages no wifi connection

,

phone not switching to 4g from wifi

,

telephone not switching fro mwifi to 4g