Phone dropping WiFi when idle

Discussion in 'Droid 2 Tech Issues' started by GotNoRice, Jan 1, 2011.

  1. GotNoRice
    Offline

    GotNoRice New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pleasant Hill, CA
    Ratings:
    +0
    I haven't had any issues connecting to and using my WiFi connection, except for this relatively minor quirk.

    Every time my phone has been sitting on my desk or whatever with the screen off and I pick it up to use it, I see that it has switched automatically back to 3g. Within several seconds of turning the screen on and unlocking the phone the WiFi will reconnect automatically.

    Why isn't it staying connected to WiFi all the time?

    I can't think of any legitimate reason why it would switch back to 3G when the phone is idle other than attempting to use up as much of my data plan as possible. I know that is a bit paranoid but my previous phone was an older Razr where you couldn't even get the pictures off it yourself because Verizon thought that would be an easy way for them to make more money, and you can't check your voicemail without calling in and using your minutes, where they make you listen starting with the oldest message first, etc.
     
  2. mewshi
    Offline

    mewshi Member

    Joined:
    Nov 13, 2010
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    It's probably just trying to save on power. Inactive 3G probably uses less power than the two radios both being on ;)

    Sent from my DROID2 using DroidForums App
     
  3. trook
    Offline

    trook Member

    Joined:
    Sep 4, 2010
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lake Elsinore Ca
    Ratings:
    +0
    you need to change your wifi sleep policy to never, you need to go into your wireless settings, then click on wifi settings, then hit the menu button (the 4 squares on the bottom left), then at the top you will see wifi sleep policy, tap it and set to never, then menu, save. now it will always stay connected......
     
  4. GotNoRice
    Offline

    GotNoRice New Member

    Joined:
    Jan 1, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pleasant Hill, CA
    Ratings:
    +0
    Thank you!!!

    The power saving explanation made sense however it seemed odd that it was still doing it when plugged in. I have an expanded battery and also almost never go more than about 6 hours without having it plugged in so battery life has not been a huge issue thus far.
     
Search tags for this page
after phone is idle wifi connection lost
,
android connection wifi lost when idle
,
android wifi drop idle
,

iphone idle wifi

,
my phone drops wifi when idle
,
s4 wifi off when phone left idle
,
s4 wifi turns off when inactive
,
wifi becomes inactive in android
,
wifi dropping when phone left in idle
,
wireless drop when phone inactive