Phone calls failing, a lot.

Discussion in 'Hashcode D3' started by ssj11mav, Mar 2, 2012.

DroidForums.net is the premier Android Forum - Registered Users do not see these ads. Please Register - It's Free!
  1. ssj11mav
    Offline

    ssj11mav Member

    Joined:
    Sep 16, 2011
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    CM9 rom, sometimes when I call someone it dials out... but there's no sound at all. I'm not sure whether it's because I use google voice, because google voice on and off produce the same problem. It calls someone... but theres no sound on my end.

    Restarting did nothing. It wasn't until I turned Airplane mode on and back off that it started working again.
  2. Mrkanyewest
    Offline

    Mrkanyewest New Member

    Joined:
    Jan 16, 2012
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Had one instance recently where my calls were being shown as connected but not going through (or at least not giving me audio), but a restart fixed that.
  3. ryu000
    Offline

    ryu000 New Member

    Joined:
    Mar 8, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    got this issue too...
    hope this could be fixed ;)
  4. imTousey
    Offline

    imTousey New Member

    Joined:
    Sep 6, 2010
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    I was having this problem yesterday while I was trying to get in contact with family, I kept calling them and I couldn't hear any audio. After reinstalling a few different nightly builds (even ones where calling had previously worked), nothing was working. Even voice search was broken. I finally realized that somehow bluetooth had been turned on (d'oh!), and turning it off fixed the problem.
    • Like Like x 1
  5. ssj11mav
    Offline

    ssj11mav Member

    Joined:
    Sep 16, 2011
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Did it to me again. This time bluetooth wasn't even on! My GPS was on, but turning that off did nothing. After about 3 times of failed calls I turned bluetooth on and back off. Speaker finally started working. My mother, however, was not too happy that her phone ringed 3 times with me not answering...

    This is becoming a nuisance and a dealbreaker. I might just have to switch to gingerbread, which is something I REALLY don't wanna do but if I have to I will.

    Also, Skype is randomly calling people. If I let the phone sleep while a chat is open, it'll call them sometimes. I have NO idea why this happens.

    Edit: Just so we're clear. I don't use Bluetooth at all.
  6. seaniscrazy
    Offline

    seaniscrazy New Member

    Joined:
    Sep 8, 2011
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Vista, CA
    Ratings:
    +1
    I am also having this problem. When I make a phone call or receive one, they can't hear me and I can't hear them. Voice search or anything that uses the mic doesn't work. I turned the bluetooth on and back off and now it works. It looks like the problem has to do with the bluetooth.

    Sent from my XT862 using DroidForums
    • Like Like x 1
  7. Danis
    Offline

    Danis Member

    Joined:
    Nov 4, 2011
    Messages:
    46
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Toronto, Canada
    Ratings:
    +1
    I'm having the exact same problem on the 3/15 nightly with my XT860. I'm trying to recreate conditions for the cause of the issue, but am unable to. It seems to happen at "random". The only way to test is to dial a number and blow into the mic to see if I can hear myself echoing through the earpiece.
    I also noticed another issue where my phone lost all signal while I was on Wi-Fi, but airplane mode fixed that.
  8. seaniscrazy
    Offline

    seaniscrazy New Member

    Joined:
    Sep 8, 2011
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Vista, CA
    Ratings:
    +1
    The way I test it is by trying to use anything that uses voice recognition. If the problem is happening then the voice recognition will fail or not pick up my voice.
    I also haven't been able to find the cause, it just happen randomly from what I can tell.
    I have that issue too. While I'm on wifi it just randomly disconnects and doesn't go to 3g right away. If i wait a minute or 2, then usually everything reconnects itself.

    Sent from my XT862 using DroidForums
  9. Danis
    Offline

    Danis Member

    Joined:
    Nov 4, 2011
    Messages:
    46
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Toronto, Canada
    Ratings:
    +1
    I upgraded to yesterday's nightly, then I did a wipe-cache. I haven't experienced the problem, it's been running for almost 12 hours straight.. I'll continue to check and update this thread later tonight.
  10. cloudstrife05
    Offline

    cloudstrife05 Member

    Joined:
    Feb 10, 2010
    Messages:
    854
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Maryland
    Ratings:
    +1
    This seems to be an issue with all ICS ROM's. (my experience anyway) As much as I love them, I gotta stick with GB for now untill that issue is fixed. I can sometimes deal without having a camcorder, but I need my phonecalls to go through.
  11. warpgamer
    Offline

    warpgamer New Member

    Joined:
    Dec 23, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Here is one temporary fix

    For the no-sound bug when calling or recieving a call, I found a fix; it was discovered by twistedddx, on XDA Dev (link to the original post: [ROM][WIP] Unofficial CM9 Port - Alpha 5 - Page 42 - xda-developers)
    Works with no bluetooth for me, even if I have to do this thing everytime I call someone. (SGSII Insanity (CM9 derivate) SiyahKernel)
    Quote : “Related to the “dial pad touch tones” “touch sounds” ” screen lock sound” or any other sound that is made prior to making an outbound call fixing the no call audio issue.

    When your bluetooth connects make a call(no audio), eg to voicemail, bring up dialpad and press a digit(tone should be heard). End call and call again, audio will now be functional.
    Any time bluetooth connects or disconnects you must force the phone to make a system sound to the ouput, eg handset or bluetooth, or you will suffer no audio bug.”
    Hope it will help,
    Warpgamer.
  12. nu2droid
    Offline

    nu2droid Member

    Joined:
    Jul 18, 2010
    Messages:
    419
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    See avatar
    Ratings:
    +2
    I have had this issue with every ICS rom I have tried. The only thing I found to fix it was to cycle airplane mode. And that don't even do it every time.

    Sent from my DROID3 using Tapatalk 2
  13. warpgamer
    Offline

    warpgamer New Member

    Joined:
    Dec 23, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Read the post just before yours; this works fine with me.
  14. nu2droid
    Offline

    nu2droid Member

    Joined:
    Jul 18, 2010
    Messages:
    419
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    See avatar
    Ratings:
    +2
    That may work when placing a call, but what about when receiving one?
    I have had that happen just as often. The phone would ring, I would answer it and there would be no sound.
  15. warpgamer
    Offline

    warpgamer New Member

    Joined:
    Dec 23, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    QUOTE=nu2droid;2172471]That may work when placing a call, but what about when receiving one?
    I have had that happen just as often. The phone would ring, I would answer it and there would be no sound.[/QUOTE]

    Well, usually, I cancel the call while ringing, call back the one who called me, and apply this procedure.. it's really annoying yeah.
    Aren't you hearing about a second of sound in the first 30 seconds of the call ? This means the dialer app can access sound hardware, but smth is blocking it, maybe deciding the app is no more granted access to audio output, or a second entity is taking audio access over the dialer (maybe a second inactive instance of the dialer working in background..). I really dont know what could be.
    But we will do anything to keep ICS on our phones, won't we ? X)
Search tags for this page
call fix cm9
,
cm9 call fix
,
cm9 call not receive
,
cm9 how to fix call issue
,
cm9 no sound in calls
,
cm9 phone not ringing
,
phone calls bug cm9
,
reason for call failed without ringing in s3
,

unable to answer a phone call on cm9

,

unable to answer to the calls on cm9