Permission Denied w/ scripts

Discussion in 'Bugless' started by Doc_PT, May 27, 2010.

  1. Doc_PT

    Doc_PT Member

    Joined:
    May 4, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Just upgraded to 1.1 from 1.0. All went smooth but now I get "permission denied" on terminal emulator when trying to change to Pete's boot animation (droidboot). I have tried fixperm without success. Any ideas?
     
  2. cpjr

    cpjr Senior Member

    Joined:
    Dec 20, 2009
    Messages:
    1,596
    Likes Received:
    0
    Trophy Points:
    66
    Location:
    Atlanta
    Ratings:
    +0
    did you type "su" first to give you super user status?
     
  3. peteralfonso

    peteralfonso Premium Member
    Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Did you install anything that was not available via my OP?
     
  4. RobStemen

    RobStemen Member

    Joined:
    Dec 31, 2009
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    Ratings:
    +0
    I had the same problem. Just type chmod 755 /system/xbin/*
     
    #4 RobStemen, May 27, 2010
    Last edited: May 27, 2010
  5. Doc_PT

    Doc_PT Member

    Joined:
    May 4, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I typed su first - guess if forgot to mention that.

    I did install Marty4Short's blue theme over the top. I had that with 1.0 without a problem. Didn't think about that - could it be the problem?

    Thanks for the help!
     
  6. peteralfonso

    peteralfonso Premium Member
    Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yes, that is the problem. Anything not in my OP will break the permissions of many things. To fix

    chmod 777 /system/xbin/fixperm
    fixperm
     
  7. Doc_PT

    Doc_PT Member

    Joined:
    May 4, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    No go - I get "Unable to chmod: Read only system. Then with sysrw get permission denied again. Guess I'll have to do without a blue theme for now. The ROM is crazy fast though!
     
    #7 Doc_PT, May 27, 2010
    Last edited: May 27, 2010
  8. peteralfonso

    peteralfonso Premium Member
    Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    To mount read write:

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
     
  9. RobStemen

    RobStemen Member

    Joined:
    Dec 31, 2009
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    Ratings:
    +0
    Just type mount -o remount,rw /dev/null /system
    Same idea as sysrw, just easier.
     
  10. Doc_PT

    Doc_PT Member

    Joined:
    May 4, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I reflashed 1.1, ran the scripts, then applied the theme which got the boot animation on(I was impatient!). I ran the additional scripts and now the permissions are fixed as well.

    Thanks again for the help.
     
    #10 Doc_PT, May 27, 2010
    Last edited: May 27, 2010
Search tags for this page
-sh: script permission denied
,

android chmod permission denied

,

android script permission denied

,
chmod android terminal emulator
,
fixing permission sh script android
,
permision dennied terminal emulator fix
,
permission denied como resolver no android
,
terminal android ./ permission denited
,
terminal emulator android permission denied
,
terminal emulator permission denied