"Package was not signed correctly"

Discussion in 'Motorola Droid X2' started by Bigtank2685, Nov 27, 2011.

  1. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello, my name is Chris, this is my first post here and I have admittedly lurking here for a while, but my current issue has prompted me to post.

    I have a rooted Moto X2, and I am getting the "package not signed correctly" message when I try to install some apps, specifically when updating google voice and super user.

    How do I go about fixing this, if there is a fix.

    My X2 is running Eclipse RC2 gb 4.2.2 with Go Launcher EX (not sure if that matters.

    Any help?

    Sent from my DROID X2 using DroidForums
     
  2. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    EDIT: 4.2.4, not .2

    Sent from my DROID X2 using DroidForums
     
  3. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Wow im dumb... GINGERBREAD 2.3.4... Don't know why I said 4...

    Sent from my DROID X2 using DroidForums
     
  4. djspy

    djspy Member

    Joined:
    Aug 19, 2010
    Messages:
    643
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    N. California
    Ratings:
    +14
    I had the exact same problem on my D1 last week. I un rooted to get the FRK update and after i did that i got that message trying to update the Google (and only Google) apps. Except for YouTube. I did everything, master reset, format sd card, unistall updates to the market, erase data from market, erased the cache nothing did the trick!

    Something bad happened when i installed the OTA FRG83G update to unroot so I rooted the device and un rooted using this method http://www.droidforums.net/forum/re...ck-2-2-without-sbf-rsd-lite-droid-1-only.html and everything worked fine after that.

    I know you said you have a Droid X but maybe you need to un root back to stock and root again like i did?
     
  5. Shadez

    Shadez Super Mod/News Team Staff Member Premium Member

    Joined:
    Jan 27, 2010
    Messages:
    8,423
    Likes Received:
    205
    Trophy Points:
    193
    Location:
    Lafayette Hill, Pa
    Ratings:
    +206
    Current Phone Model:
    HTC One M8
    Twitter:
    @Shadez69
    Welcome to the forums! :) Hope you get you're prob solved!
     
    Last edited: Nov 27, 2011
  6. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks djspy! i will check that out!
     
  7. djspy

    djspy Member

    Joined:
    Aug 19, 2010
    Messages:
    643
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    N. California
    Ratings:
    +14
    You're welcome, I hope you get the issue resolved!
     
  8. JSM9872

    JSM9872 DF Super Moderator Staff Member Premium Member

    Joined:
    Dec 21, 2010
    Messages:
    12,922
    Likes Received:
    287
    Trophy Points:
    498
    Location:
    Pennsylvania...
    Ratings:
    +287
    Current Phone Model:
    Galaxy Note 3
    Sorry if I am late to the party but the reason your apps will not update does have to do with the fact you are running a custom ROM. To sum it up the apps that come with the ROM, in this case the ones you are trying to update, are most likely signed with a different key then the ones from the market which makes it error out.

    For Superuser there is an app on the market to combat this. It is free and it is called "Superuser Update Fixer." Try downloading it then updating. For Google search you will most likely have to uninstall it and then download it from the market.
     
  9. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I will try the super user one, but it was google voice, not search. I have cleared data and cache a couple of times and every time, voice wont update. And ut didn't come with eclipse.

    Sent from my DROID X2 using DroidForums
     
  10. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    *it didn't

    Sent from my DROID X2 using DroidForums
     
  11. Bigtank2685

    Bigtank2685 New Member

    Joined:
    Nov 26, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ok I got SU updated, but google voice still wont update. I tried uninstalling it and reinstalling, but that didn't work, now I had to sideload a older version from the interwebs... anyone?

    Sent from my DROID X2 using DroidForums
     
  12. flip8882

    flip8882 New Member

    Joined:
    Jul 20, 2011
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    i used to have this problem with youtube not updating, i don't quite remember how it got fixed but it got to do with the rom i'd suggest reinstalling the rom. or wiping data then try
    backup your rom with cwr and do a advanced restore and get just the data back then update google.

    edit: it had to do with the Su binary
     
    Last edited: Nov 28, 2011
  13. JSM9872

    JSM9872 DF Super Moderator Staff Member Premium Member

    Joined:
    Dec 21, 2010
    Messages:
    12,922
    Likes Received:
    287
    Trophy Points:
    498
    Location:
    Pennsylvania...
    Ratings:
    +287
    Current Phone Model:
    Galaxy Note 3
    Was it a themed one or did you download it from the market originally? Just trying to figure out why it would't work because that is strange if you downloaded it from the market and it won't update. In that instance it could be a market issue.

    Maybe try uninstalling it and then rebooting. Then try installing it again.
     
  14. UrbanBounca

    UrbanBounca Rescue Squad Staff Member Rescue Squad Premium Member

    Joined:
    Sep 25, 2010
    Messages:
    2,524
    Likes Received:
    130
    Trophy Points:
    128
    Location:
    Virginia
    Ratings:
    +144
    Actually, I got the same error when trying to update GV on the stock firmware.

    Sent from my DROID2 using Tapatalk
     
  15. JSM9872

    JSM9872 DF Super Moderator Staff Member Premium Member

    Joined:
    Dec 21, 2010
    Messages:
    12,922
    Likes Received:
    287
    Trophy Points:
    498
    Location:
    Pennsylvania...
    Ratings:
    +287
    Current Phone Model:
    Galaxy Note 3
    Yeah I actually would have skipped posting that last part had I not thought I read they posted about Google search, voice is rarely a system app. But I am beginning to wonder if there is some sort of issue with GV based on the last few posts.

    Sent From a Tear in the Space/Time Continuum...
     
Search tags for this page
google search package not signed correctly
,
how to fix package file was not signed correctly
,
package file not signed correctly
,

package file was not signed correctly

,
package file was not signed correctly android
,
package file was not signed correctly whatsapp
,
package not signed correctly
,
package not signed correctly android
,

package was not signed correctly

,
whatsapp package file was not signed correctly