Not receiving emails/etc while on WiFi

Discussion in 'LG G4 Forum' started by Quacky, Oct 21, 2015.

  1. Quacky

    Quacky New Member

    Joined:
    Oct 21, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    Phone: LG G4
    Carrier: Verizon

    My phone will not receive emails/snapchats/etc while on WiFi. When I turn off WiFi and the phone connects to 4G, the notifications will flood in. I can manually refresh Gmail and emails will come in, it just doesn't happen automatically.

    I downloaded a software update on the 11th, but the problem started about a week later.

    Any tips?
     
  2. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Welcome to the forum

    What mail service are you using? Are you able to send on and off WiFi? Is this a new problem?
     
    • Like Like x 1
  3. Quacky

    Quacky New Member

    Joined:
    Oct 21, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    Gmail, but the problem is with any app that would usually give me a notification (snapchat, game notifications, new Google Opinion surveys, etc.). I can send on and off WiFi. This problem started a few days ago.
     
  4. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,468
    Likes Received:
    7,038
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,379
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Have you changed any settings recently?

    When was the last time you rebooted the phone?

    When was the last time you rebooted your router and/or modem?
     
  5. Quacky

    Quacky New Member

    Joined:
    Oct 21, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    I don't know if I've changed any settings recently, but if I did it was nothing that should have messed with WiFi or notifications. I rebooted my phone last night, and I have rebooted the router since the problem has started.
     
    • Like Like x 1
  6. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Something is missing somewhere. If it was working there is no logical reason it wouldn't still be working.
     
    • Agree Agree x 1
  7. Quacky

    Quacky New Member

    Joined:
    Oct 21, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    I'm having the same problem with the WiFi at school.
     
    • Like Like x 1
  8. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,468
    Likes Received:
    7,038
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,379
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Definitely an issue with the phone then. Very strange situation.
     
  9. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,250
    Likes Received:
    2,989
    Trophy Points:
    533
    Location:
    Central New York
    Ratings:
    +3,284
    Current Phone Model:
    Samsung Note 3
    It almost seems like it is a setting somewhere. Do you use any battery optimizer apps, such as AutomateIt or Tasker? They often have battery saving settings that will stop sync or notifications. I wonder if clearing your cache data partition would help?

    Sent from my SM-N920V using Tapatalk
     
  10. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Great point, but most of those settings work in reverse, get on WiFi only, to conserve data. This is a strange one for sure.
     
    • Like Like x 2
  11. Quacky

    Quacky New Member

    Joined:
    Oct 21, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    I've uninstalled all the apps I had like that (clean master, cm security). And I have tried cleaning my cache.

    I guess I can just change the setting to turn WiFi off when the screen is off, but that's not an ideal solution. I'll restart my phone and clear the cache again.
     
  12. LinkError404

    LinkError404 New Member

    Joined:
    Oct 26, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Verizon LG G4
    I am having the same issue on my Verizon LG G4. just my .02, this only started happening after the recent update about 2 weeks ago. I think the update was a preparation for Marshmallow sometime this coming month and i hope this issue is addressed. I'm glad to not be the only one experiencing this issue.