Not capitalizing the "i" when texting

Discussion in 'Droid 4 Tech Support' started by cgilm2526, Feb 16, 2012.

  1. cgilm2526
    Offline

    cgilm2526 New Member

    Joined:
    Feb 16, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    This is my first post so I hope I explain everything. I upgraded from the D1 to the D4 two days ago and noticed when I send a text, that the D4 doesnt capitalize the letter "i" when its by itself. I have to hit Shift to capitalize it. Is anyone else having this problem and is there a fix? Any help would be greatly appreciated.
  2. debdroid1a
    Offline

    debdroid1a New Member

    Joined:
    May 19, 2010
    Messages:
    847
    Likes Received:
    6
    Trophy Points:
    0
    I was annoyed by that too so several of my posts here don't have that.

    I just checked because I also want it corrected.
    • Settings
    • Language & Keyboard
    • Built-in Keyboard
    • Auto-Replace -- check this it will correct mistyped words. Not sure how it works on other words, but does auto correct the I to capitalize it.
  3. LadyHottShott
    Offline

    LadyHottShott New Member

    Joined:
    Feb 10, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    0
    That's werid, mine does, didn't have to do anything to it.
  4. NiteCloak
    Offline

    NiteCloak New Member

    Joined:
    Feb 13, 2012
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Michigan
    Thanks for that, I was having the same issue.

    I also wish (on the built in keyboard) that the Shift and CAPs lock button positions were reversed, and that hitting SHIFT+1 to get the exclamation mark wasn't a finger contortion feat of epic proportions.
  5. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    I also have this problem. Auto-correct is not an option for me, I HATE it. Does anyone know how to get the automatic punctuation like "I", "I'm", "We'll", etc? This worked fine on my Droid 2 with auto-correct OFF.
  6. cgilm2526
    Offline

    cgilm2526 New Member

    Joined:
    Feb 16, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    You would think that it would correct itself without having to turn on the Auto-Correct. Not a really fan of Auto-correct so was hoping that there was a fix to the "i" problem without have to use the Auto-Correct option.
  7. reybie
    Offline

    reybie New Member

    Joined:
    Jan 9, 2010
    Messages:
    269
    Likes Received:
    8
    Trophy Points:
    0
    It doesn't do that on mine. Suggestion: Add "I" in the user dictionary. See if it helps.
  8. cgilm2526
    Offline

    cgilm2526 New Member

    Joined:
    Feb 16, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Adding it to the dictionary didnt help. UGH
  9. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    We shouldn't have to use the dictionary to do this.
  10. diablo85
    Offline

    diablo85 New Member

    Joined:
    Feb 12, 2012
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    0
    you can press shift separately from 1. you dont have to hold down shift.
  11. guidot
    Offline

    guidot Developer Relations Staff Member Premium Member

    Joined:
    Feb 10, 2010
    Messages:
    7,350
    Likes Received:
    270
    Trophy Points:
    0
    Location:
    Massachusetts
    [​IMG]
    [​IMG]

    Do you have all of those selections on?

    Sent from the best 3G phone on Verizon.
  12. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    All are on other than the auto-replace. That option is not necessary to get the automatic capitalization and punctuation that we are looking for.
  13. debdroid1a
    Offline

    debdroid1a New Member

    Joined:
    May 19, 2010
    Messages:
    847
    Likes Received:
    6
    Trophy Points:
    0
    Auto-Replace is what I checked and my 'I' was capitalized after that.
  14. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    Right, but on my Droid 2 auto-replace was not required to perform the punctuation / capitalization corrections. It is designed to not require auto-replace turned on.
  15. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    The whole reason I have a physical keyboard is so that I never have to use auto-correct, auto-fill, or any automatic typing features.
  16. guidot
    Offline

    guidot Developer Relations Staff Member Premium Member

    Joined:
    Feb 10, 2010
    Messages:
    7,350
    Likes Received:
    270
    Trophy Points:
    0
    Location:
    Massachusetts
    I think that in this case you need to turn it on. Just tested it and that's what the issue is.
  17. debdroid1a
    Offline

    debdroid1a New Member

    Joined:
    May 19, 2010
    Messages:
    847
    Likes Received:
    6
    Trophy Points:
    0
    This is a Droid 4, which is different. I've noticed a lot of different setting for this then my Droid 1. I don't even remember if I had auto correct on my Droid 1 set. Even after I did a factory reset a month ago, I don't think I changed it, but that doesn't mean it wasn't automatically set.
  18. R2D|2OID
    Offline

    R2D|2OID New Member

    Joined:
    Dec 11, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    Well, the auto-correct is not an option, so does anyone have an idea for a workaround?
  19. cgilm2526
    Offline

    cgilm2526 New Member

    Joined:
    Feb 16, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    There was an option in the settings for fixing commonly mistryped words for the virtual keyboard but not one for the physical keyboard. The only options for the physical keyboard are: Auto Replace(Unchecked), Auto Punctuate(checked) and Auto Cap(Checked). So, the "i" issued is fixed on the virtual keyboard by checking the Auto Replace option, but still not on the physical keyboard.
  20. guidot
    Offline

    guidot Developer Relations Staff Member Premium Member

    Joined:
    Feb 10, 2010
    Messages:
    7,350
    Likes Received:
    270
    Trophy Points:
    0
    Location:
    Massachusetts
    I tested this last night and if you select auto replace, it will fix the capital "I" issue on the hardware keyboard. But, as explained it also replaces a lot of other words, that you may not want.

    Those are the only features though.

    Sent from the best 3G phone on Verizon.
Search tags for this page

android not capitalizing i

,
android physical keyboard does not auto-capitalize
,
android quit capitalizing i when i text
,
capitalize option rom
,
how do i get andriod keyboard to capitalize i?
,
how do i stop my phone from auto capitalization
,

how to set my android to auto capitalize i?

,

i wont automatically capitalize on samsung s3

,

samsung galaxy s3 doesnt capitalize my i

,
swype stopped capitalizing i
,

swype won't capitalize i

,
why doesnt galaxy s3 capitalize the letter i
,
why doesnt my galaxy 4 auto capitalize
,
why is my texting not capitalizibg i
,
why when i am texting the i wont capitalize on it own