Not able to read SD card

Discussion in 'Android General Discussions' started by xdegenerate, Jul 2, 2017.

  1. xdegenerate

    xdegenerate New Member

    Joined:
    Jul 2, 2017
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Samsung Grand Prime
    Hey All,

    I've got a Samsung Galaxy Prime SM-G530FZ
    Running Android 5.0.2
    With KNOX 2.4 installed

    The phone has been running fine for a while, apart from an issue where if I restart it goes into Set Warranty: Recovery Mode. And I have to boot manually. No big deal. Thats not the issue.

    Today, it just started to play up and stayed black like it had no battery left. Yet there was over 50%. It kept telling me "Touch Wiz has closed". It has done that on every start up, but comes back and doesn't say it again, but today it just kept doing it over and over. So I restarted the phone, and did a boot like usual, and I saw it updated something from Android. Something with 2 installs to it.

    Touch wiz of coarse said it screwed up as usual, but then came back and was stable. Only now all my apps on the SD card are greyed out like I'm in safe mode (which it isn't).

    I've rebooted a million times, hard shut downs, pulled the battery out, but it keeps doing the same thing. I've tried to search answers but it's so frustrating when you see solved and it's be a feature this version of Samsung doesn't have. Least I don't think Prime has a task manager anyway like those "solved" issues had.

    I rooted the phone about 4 months ago, it hasn't had an issue, until today. I don't know if its a setting been adjusted by the update, or if the update itself screwed it up.

    Also, I have checked to see if it's the SD card. It's not, it's been compatible, no problems, and all the data is still on there and fine when I checked it via PC.

    Can anyone help out with this issue, please?

    Thank you
     
  2. me just sayin

    me just sayin Gold Member

    Top Poster Of Month

    Joined:
    Jun 7, 2017
    Messages:
    2,638
    Likes Received:
    1,159
    Trophy Points:
    348
    Location:
    35.7051° N, 89.9695° W
    Ratings:
    +1,239
    Current Phone Model:
    Note 8
    did you try deleting the system cache. if not, give it a try



    1. Turn off the device.

    2. Press and hold the Volume Up key and the Home key, then press and hold the Power key.

    3. When the Samsung GALAXY GRAND Prime logo screen displays, release only the Power key

    4. When the Android logo displays, release the Volume Up and the Home key ('Installing system update' will show for about 30 - 60 seconds before showing the Android system recovery menu options).

    5. Press the Volume down key several times key to highlight 'wipe cache partition.'

    6. Press Power key to select.

    7. When the wipe cache partition is complete, 'Reboot system now' is highlighted.

    8. Press the Power key to restart the device.
     
    • Like Like x 1
  3. xdegenerate

    xdegenerate New Member

    Joined:
    Jul 2, 2017
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Samsung Grand Prime
    Hi Me Just Sayin,

    I tried what you advised. But in step 4, I don't get any update happening, it just goes to the recovery menu. Just before it, it shows that yellow robot icon thing lying on its back, with a red triangle and a ! on it for a split second, then goes to system recovery. In which looking for an image of it on google, there is a pic saying its a "no command error in recovery mode"?

    I'm not sure what the rules are on linking to pictures, so I will just say I found it on google image search by typing "android robot icon error" if you need to see it.

    Three other things I have noticed.
    1. When the phone boots up, after the samsung logo, it goes to a black screen where I can see nothing but the time, battery percentage and a no smoking style circle because it hasn't connected to wifi yet. THEN, the "unfortunately, Touch-wiz home has stopped running" comes up. If I press OK, it it actually starts up again showing my background image and icons, even tho I have the phone set to a lock screen first... then it turns black again and loads the lock screen, so I have to swipe to get back in yadda yadda.

    2. On my shortcuts pages, I see apps, all I had except for two which are partitioned to the SD card... yet, if I click on the APPS icon, those apps are not listed in there!

    3. Sometimes when it goes into standby/the screen goes off. When I press the power button or home button, the phone doesn't come back on right away. It just stays off for a couple of seconds, then eventually comes back on, and works fine (except for these issues)

    I wondered maybe also if my phone un-rooted itself? But Root Checker Basic says i'm still rooted. So this is really puzzling me?
     
  4. me just sayin

    me just sayin Gold Member

    Top Poster Of Month

    Joined:
    Jun 7, 2017
    Messages:
    2,638
    Likes Received:
    1,159
    Trophy Points:
    348
    Location:
    35.7051° N, 89.9695° W
    Ratings:
    +1,239
    Current Phone Model:
    Note 8
    so in step four you do not get the recovery menu? if not, then imo, there is something major going on and the phone could be corrupted. you may need to unroot it in order to get things going again. go to the site you got the root from and see if others had similar problem or to get instructions to unroot.
     
  5. xdegenerate

    xdegenerate New Member

    Joined:
    Jul 2, 2017
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Samsung Grand Prime
    sigh, I was afraid of that.

    Thanks. I'll try unrooting.
     
Search tags for this page

sd card not showing on phone