No way to turn off caller ID. Driving me crazy

Discussion in 'Android Tech Support' started by hahnwald, Dec 7, 2012.

  1. hahnwald
    Offline

    hahnwald New Member

    Joined:
    Dec 7, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    After the last update to Android 4.1.1, my RAZR M announces all incoming calls. I have checked all settings in sound and accessibility. None are checked and I have spent 2 hours talking to Verizon's technical support without resolution to my issue. It is extremely annoying. Other than a factory reset, what else might I try. The phone is new so I have few apps-weather, currency conversion, and a spam control so I don't think it's an ap conflict. What else? Thank you
  2. Bacchus224
    Offline

    Bacchus224 New Member

    Joined:
    Nov 6, 2012
    Messages:
    12
    Likes Received:
    2
    Trophy Points:
    0
    Have you gone to the phone screen and then clicked the menu button and selected settings?

    Scroll down to caller ID readout. That's how I turn my readout on.
    1 person likes this.
  3. hahnwald
    Offline

    hahnwald New Member

    Joined:
    Dec 7, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Need help turning off caller ID

    Thanks for the reply. Under the droid release I have, caller ID is under the accessibility choices within the settings menu. Talkback is off and within the settings under it, speak caller ID is not checked.
  4. Miller6386
    Online

    Miller6386 Developer Developer

    Joined:
    Oct 22, 2011
    Messages:
    524
    Likes Received:
    96
    Trophy Points:
    28
    Location:
    Beer Tent Capital of The World
    Ok I am not sure where it is on the Droid M but look for Car Mode or Driving Mode and make sure that is OFF.... I know a TON of people who had this issue with the S3... For some reason that turns on with the JB update....
  5. TisMyDroid
    Offline

    TisMyDroid New Member

    Joined:
    Feb 16, 2011
    Messages:
    4,453
    Likes Received:
    353
    Trophy Points:
    0
    Location:
    Central New York
    On my Razr M, caller ID readout is located in the settings of the stock phone app. Select ring only.

    Sent from my XT907 using Droid Forums
  6. hahnwald
    Offline

    hahnwald New Member

    Joined:
    Dec 7, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Can't turn off caller ID

    Thanks so much for this suggestion. My version of Android doesn't seem to have either car mode or driving mode.
  7. Miller6386
    Online

    Miller6386 Developer Developer

    Joined:
    Oct 22, 2011
    Messages:
    524
    Likes Received:
    96
    Trophy Points:
    28
    Location:
    Beer Tent Capital of The World
    Double check these locations and verify......Pull down the notification bar, scroll toward the right side of the toggles and make sure Driving mode is turned off. Alternative method - Settings / Language and input / Text-to-speech output / Driving Mode (off)
  8. razrron
    Offline

    razrron New Member

    Joined:
    Dec 16, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I also have a Razr M running 4.1.1. Unfortunately none of the suggestions work thus far including setting to ring [only] and so many other suggestions. Text-to Speech Output under Language & Input / Speech only has two options "settings for Google text-to-speech' and 'install voice data'. Driving mode isn't there. Text-to-speech is also available under Accessibility and the only options there are Speech rate and Listen to an example. Smart Actions does have a 'Drive' feature but that is off. I've rebooted after trying different suggestions but nothing works so far.
  9. TisMyDroid
    Offline

    TisMyDroid New Member

    Joined:
    Feb 16, 2011
    Messages:
    4,453
    Likes Received:
    353
    Trophy Points:
    0
    Location:
    Central New York
    For talking caller ID, open the stock phone app, go to its settings (three vertical dots near the top right), scroll down to “Caller ID readout" and select ring only.

    Sent from my XT907 using Droid Forums
  10. razrron
    Offline

    razrron New Member

    Joined:
    Dec 16, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Thanks but the phone app / settings / caller ID Readout / was set to 'ring only' but it didn't stop the talking ID. I've thought that it might be related to another app that is overriding the phone settings. For example, I removed Skyvi but that didn't help either.
  11. razrron
    Offline

    razrron New Member

    Joined:
    Dec 16, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Talking ID problem Solved! I "unplugged" SmartActions / Drive / Announce calls and texts. Even though this "Manual Action" was (and is) turned off, by unplugging the Announce calls..., it stopped the announcements. Finally.
  12. hahnwald
    Offline

    hahnwald New Member

    Joined:
    Dec 7, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    How do I do this?


    How do I do this? Thanks
  13. razrron
    Offline

    razrron New Member

    Joined:
    Dec 16, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    SmartActions

    To "unplug" the triggers or options in the SmartActions app, go to the 'My Manual Actions' and click on 'Drive'. Then slide the 'Announce calls and texts' to the right (note it is plugged in when slid to the left). Also, and I just noticed this, ensure the 'My Smart Actions' / 'Announce calls and texts' Action under Battery Saver is also unplugged (i.e., slide to the right). I had to take that action also otherwise I would get announcements during the day.
  14. mollycule
    Offline

    mollycule New Member

    Joined:
    Jan 6, 2013
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Still nothing...

    Hi! I'm glad this forum is recent, as I'm having the same issue...
    I just got a Droid RAZR M last month, with 4.1.1 Jellybean. Same for me, most of those settings in solutions provided earlier don't exist in 4.1.1.
    I also checked SmartActions - I don't even have the Drive one turned on, and I checked the Battery Saver, it's not even under the Actions section - I would have to add it. However, I can't find any "My Manual Actions" section.
    Any other places I can find the option to turn it off? I've already checked in Accessibility to make sure Talkback was turned off.
  15. hahnwald
    Offline

    hahnwald New Member

    Joined:
    Dec 7, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Still driving me crazy


    I keep hoping someone will come up with a fix. I started this post and still have the problem. I have been through every setting very carefully. Like you, I do (did) not have SmartActions installed. My husband has the identical phone ( we got them in the same shipment) and I have matched his settings against mine. He does not have the problem. I believe we need a fix from Jellybean.
  16. amkor
    Offline

    amkor New Member

    Joined:
    Apr 27, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    My daughter and I got the same phone, Motorola Droid Razr M just yesterday.... I had the same issue described above, maybe with a slight twist: whenever she would call me, my phone would sound a female voice announcing "Verizon Wireless" before it would ring (how helpful to know the caller is "Verizon Wireless" indeed...)... Interestingly enough, my daughter (same exact phone) doesn't have this "feature" when I call her....

    After spending some time experimenting, I THINK I found a workaround...

    I created a manual SmartAction WITHOUT a trigger (couldn't find any in the list that fit the situation, so I just left it blank), and the action I chose was "announce Calls and Text" —— I selected the first option, "text message sender name" while the 2nd one, "incoming caller name" is de-selected.

    It works......
  17. mollycule
    Offline

    mollycule New Member

    Joined:
    Jan 6, 2013
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    How have I never found this section of settings! FINALLY solved my problem. Thanks!
Search tags for this page

android disable caller id

,

android turn off caller id

,
android turn off voice caller id
,
caller id disable android
,
disable caller id readout
,

droid razr caller id readout

,
galaxy note 2 talking caller id
,
hide incoming caller id android
,

how to turn off voice caller id on android

,
jelly bean turn off caller id
,

turn off caller id announce android

,

turn off caller id readout android