No GPS and No Recovery

Discussion in 'Bugless' started by iGuess, Aug 31, 2010.

  1. iGuess

    iGuess New Member

    Joined:
    Jun 19, 2010
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I finally switched to BB after disappointment with other ROMs. Did a fresh install, and GPS is not working. If I try to refresh the weather, I get the GPS icon in the status bar... forever. It can never acquire a location, and just sucks down battery. Same with maps, places, navigation, etc.

    I'm also unable to boot into clockwork recovery. Is this more likely a ROM manager problem, or something caused by BB? Never had this problem before. If I try to boot into recovery, I just get the motorola logo for a very long time, before I guess it gives up and boots normally.
     
  2. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    First thing to solve is the Clockwork issue. You hit the nail on the head when you stated it was probably a Rom Manager issue. It is. Go into RM and scroll down to the bottom and Flash Alternate Recovery. After that has completed, then reflash Clockwork. Continue to reflash Clockwork until completes the install quickly (5-10 seconds). I also recommend then scrolling down to the Older Versions of Clockwork and install the 2.01.3 version as it seems to be more stable than any of the newer ones (ymmv!).

    One more note on Clockwork: If you decide to stick with Clockwork instead of SPR, you need to pay attention when you first get into the app. If it is non-responsive, be prepared to press the X key if it reboots. If you get the X pressed quickly, the reboot will take you right back to Clockwork and it will work fine from that point on and you do whatever you originally booted into Clockwork for.

    Now the GPS, to me would mean it was time to reload the rom. Because that is not a common issue with any of the current roms. I would reboot into recover and do one to three wipes (based on how OCD you are) and then reinstall the rom.

    Good luck.