New Compcache/GB Kernels - 2/11/11

Discussion in 'ChevyNo1' started by ChevyNo1, Feb 11, 2011.

  1. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    That definitely is weird - I have been connected SOLID (no drops) for two DAYS now on WPA2 ...
     
  2. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    What errors? Is it scanning?
     
  3. undroid

    undroid Member

    Joined:
    Jun 5, 2010
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    No errors other than scanning then back to disconnected.
     
  4. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    Hmm, the 'back to disconnected' is a problem for sure!

    OK - in terminal - type this in:

    lsmod

    If you do not see tiwlan, then type this:

    insmod /system/lib/modules/tiwlan_drv.ko

    What does it say?
     
  5. undroid

    undroid Member

    Joined:
    Jun 5, 2010
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    i do see tiwlan_drv loaded. i rmmod and did the insmod and no errors.

    here's logcat:
    V/WifiStateTracker( 1250): Changing supplicant state: DISCONNECTED ==> SCANNING
    I/dalvikvm( 1802): Jit: resizing JitTable from 4096 to 8192
    D/dalvikvm( 1802): GC_FOR_MALLOC freed 8308 objects / 500104 bytes in 43ms
    I/wpa_supplicant( 1949): Trying to associate with 00:22:2d:xx:xx:xx (SSID='PUBLIC-WIFI' freq=2422 MHz)
    I/wpa_supplicant( 1949): CTRL-EVENT-STATE-CHANGE id=-1 state=3 BSSID=00:22:2d:xx:xx:xx
    V/WifiMonitor( 1250): Event [Trying to associate with 00:22:2d:xx:xx:xx (SSID='PUBLIC-WIFI' freq=2422 MHz)]
    V/WifiMonitor( 1250): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=3 BSSID=00:22:2d:xx:xx:xx]
    V/WifiStateTracker( 1250): Changing supplicant state: SCANNING ==> ASSOCIATING
    E/wpa_supplicant( 1949): Ongoing Scan action...
    D/WifiStateTracker( 1250): Reset connections and stopping DHCP
    D/dalvikvm( 1759): GC_EXPLICIT freed 9432 objects / 528472 bytes in 71ms
    D/WifiStateTracker( 1250): Disabling interface
    D/NetworkStateTracker( 1250): setDetailed state, old =CONNECTING and new state=DISCONNECTED
    D/ConnectivityService( 1250): ConnectivityChange for WIFI: DISCONNECTED/DISCONNECTED
     
  6. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    OK - can you redownload/install one of my kernels from the kernels thread and try again? Want to ensure you have the latest.
     
  7. undroid

    undroid Member

    Joined:
    Jun 5, 2010
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    redownloade; is the following the latest?
    uname -a
    Linux localhost 2.6.32-lowV-1.0Ghz-ChevyNo1 #306 PREEMPT Tue Feb 22 12:51:30 MST 2011 armv7l GNU/Linux
     
  8. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    Hmmm yes it is - I am on wireless right now, and have been for 2 days straight with no drops - I don't understand why yours keeps disconnecting!
     
  9. undroid

    undroid Member

    Joined:
    Jun 5, 2010
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    well my problem is not disconnecting problem that other people are having. my problem is it does not connect at all. it scans, connecting, disconnecting. fyi i can connect fine at home but at work i cannot connect to wifi. with your older kernels i was able to connect to both wifi's. thanks for all your time and help on this.
     
  10. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    Yep, I know your issue is different - but mine will STAY scanning - every few seconds it says 'scanning' - yet never disconnects. I cannot replicate your issue, NOR the issues others are having ...
     
  11. jrmdroid

    jrmdroid Member

    Joined:
    Aug 20, 2010
    Messages:
    225
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Chicagoland
    Ratings:
    +3
    This is what I did after it stopped working after a reboot. Deleted the data and redid my wifi stuff. Once I did that it started to work.

    Edit: my bad. I restored from a TB backup of wifi access points I had. Then it started to work again.

    Sent from my Droid using DroidForums App
     
  12. juhde

    juhde Droid X Rescue Squad
    Rescue Squad Premium Member

    Joined:
    May 4, 2010
    Messages:
    420
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    New Mexico
    Ratings:
    +3
    So here's a screen cap of cat log, the first entry is from the phone being connected but unable to access the internet, the second is after I restart wifi. Hope this helps chevy.
    [​IMG]

    Sent from my Droid
     
Search tags for this page

ext3.ko 2.3.7 android 2.6.32.9

,

wpa supplicant:ongoing scan action