New Bug: Text Extry won't stay within focussed password field

Discussion in 'xScope Mobile' started by wernst, Mar 31, 2010.

  1. wernst

    wernst Member

    Joined:
    Feb 23, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    OK, I am unable to enter my password into a specific website I use all the time.

    What happens: I go to this website. There is a login name field and password field. I tap the login name field and start typing my username. Then I tap the password field - the password field gets a golden "halo" to indicate it is selected. Now the bug: any text I type winds up appended to the end of the login name field text.

    I've tried this in portrait, landscape, and with the physical keyboard. I've used the D-pad to try to select the password field, and the text still doesn't get input.

    And BTW this works fine in the default browser.

    Now then, here's how you can test this yourself.


    1. Create a free account for yourself at Remember The Milk. The URL is: Remember The Milk: Online to do list and task management. Use a desktop browser for this.
    2. Add a few tasks for yourself. Again, use a desktop browser.
    3. Now go to a portable-friendly version of this list using this URL with xScope: Remember The Milk Homepage Module
    4. Now try to login. I bet you can't enter your password. That's the bug. BTW, this URL is what iGoogle uses to display my RTM tasks. I can't login when this info is displayed within iGoogle either, but these steps makes it easy to show you what's happening.

    Thanks,
    Warr
     
  2. jasvll

    jasvll New Member

    Joined:
    Mar 10, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've had this problem with the stock and dolphin browsers. I was able to solve it by fully closing the browser (not just hitting the home button), then restarting it.
     
  3. wernst

    wernst Member

    Joined:
    Feb 23, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I can confirm that this DOES NOT HELP in this situation. Fortunately, I've provided the exact steps anyone needs to confirm this for themselves.

    -Warr
     
  4. garysui

    garysui Member

    Joined:
    Nov 29, 2009
    Messages:
    317
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
  5. wernst

    wernst Member

    Joined:
    Feb 23, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Sorry, but you are not going to the right page. You need to go to the link in Step #3 of my list and try to log in with xScope, as I said. Based on your screenshot, you are using xScope to log into the site on Step 1.

    Please reread and try again.

    Thanks,
    Warr
     
  6. wernst

    wernst Member

    Joined:
    Feb 23, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Note that if you are still logged into the page from Step 1 in xScope and have told xScope to remember you password, you will be able to goto the link in step 3 without logging in. So, be sure to log out from RTM firstt BEFORE trying this so that you can attempt to log in.

    -Warr
     
  7. garysui

    garysui Member

    Joined:
    Nov 29, 2009
    Messages:
    317
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    You are right I wasn't using the portal.
    However, as jasvll has said, this is webkit's behavior that I have no control of. Really sorry about this one.

    I suggest you send milk an email about this. They can fix it from server side.

     
  8. wernst

    wernst Member

    Joined:
    Feb 23, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I'll forward this along to the RTM people. Thanks for checking.

    -Warr
     
Search tags for this page

android 4.3 webview can't type into input field

,

android webview input field double

,

android webview password