Navigation/Maps stopped working after recent update

Discussion in 'Android Tech Support' started by Liderc, Jul 12, 2013.

  1. Liderc
    Offline

    Liderc New Member

    Joined:
    Dec 14, 2009
    Messages:
    2,265
    Likes Received:
    43
    Trophy Points:
    0
    Recently updated Google Maps and possibly Nav, which seems to have combined them apparently. Now it doesn't work at all. It asks me to put in a location, but never finds my location. I try to put in a destination and it never finds the destination, just says no network connection - which is obviously incorrect since I have full LTE bars, also tried with WIFI. I've removed the battery/SIM rebooted multiple times. Have never had a Nav problem ever with my Galaxy Nexus (Stock), and now I update maps and can't access maps/nav at all so it's obviously the update but I'm only seeing a handful of people complaining about a similar issue, although their problem seems to be that they can't find the maps icon, which isn't a problem I have.

    In my settings it says that I'm using Maps version 7.0.1, I'm uninstalling it right now and going to reinstall, will post again if that corrects the issue.

    Edit: Looks like I can only uninstall the updates, not the entire application. Doing this removed all updates and brought me back to stock which has fixed the issue, but I would like to be up to date. If anyone else is having this problem with 7.0.1 on the Galaxy Nexus, please let me know.

    Any help is appreciated.
    Last edited: Jul 12, 2013
  2. volvomann
    Offline

    volvomann New Member

    Joined:
    Oct 3, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Eureka, Ca. on the Pacific
    I think they fixed it for ver 7.0.1

    Mine also was messed up this afternoon and evening...I came here to see if I was alone.
    It's working fine now...they must have fixed it ;o)
    -=Greg=-
  3. Liderc
    Offline

    Liderc New Member

    Joined:
    Dec 14, 2009
    Messages:
    2,265
    Likes Received:
    43
    Trophy Points:
    0
    Was there another update on your end Volvo? I don't want to update again if it's just going to break it again. Could you also verify that you're also on 7.0.1. Can check by going to settings, apps, then click on Maps.
  4. Liderc
    Offline

    Liderc New Member

    Joined:
    Dec 14, 2009
    Messages:
    2,265
    Likes Received:
    43
    Trophy Points:
    0
    Little update. I uninstalled all the updates to Google Maps, then back at stock everything worked but I wanted to get back up to date. So I found the Maps update on the store, updated it manually, and so far it looks like it's working.

    So if anyone else runs into this problem with 7.0.1 Maps app try this in order:

    1. Reboot phone, remove battery and sim, push power button to reset. Put everything back in and turn on.
    2. Go to apps, click on maps, settings, uninstall updates and clear data.
    3. You can test nav now, it should work as it originally did.
    4. If you want the most up to date maps/nav go to 5.
    5. Go to the app store, search google maps, download the updates and install.
    6. Once you've installed the new Maps updates, it will look different, but you shouldn't have connection issues.

    Should be able to select a destination and be good to go. There's an additional step now, where you have to click start to start the drive, but it's easy enough.
    Last edited: Jul 14, 2013
Search tags for this page
android maps app not working
,
android navigation not working
,
google maps app not working
,
google maps navigation not working
,
google maps not working on android
,

google navigation app not working

,

google navigation not working

,
google navigation stopped working
,
maps app not working on android
,
navigation app for android not working
,
navigation app not working
,
why is my navigation app not working