My Milestone's screen doesn't turn on, however, I'm able to see some blacklight.

Discussion in 'Android Support' started by Hydranalin, Feb 20, 2014.

  1. Hydranalin

    Hydranalin New Member

    Joined:
    Feb 20, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    My Motorola Milestone "died" about 1 year ago, and I just didn't have time to do anything about it.
    Whenever I try to turn it on, the screen shows a little backlight, but neither the "M" logo nor the android logo appears.
    Another interesting thing is, that the phone itself is completely functioning even without the screen.
    By that I mean: -When I pull my fingers across the screen, I can still feel the phone vibrating, which means that eventhough the screen doesn't work,
    the system is in a normal condition.

    (Also, I've tried every single trick I read about, and yet none of those seemed to help)


    ANY SUGGESTIONS?
     
  2. CJM

    CJM Super Moderator
    Staff Member Rescue Squad Premium Member

    Joined:
    Sep 12, 2010
    Messages:
    10,639
    Likes Received:
    1,717
    Trophy Points:
    558
    Location:
    Mississippi Gulf Coast
    Ratings:
    +1,859
    Current Phone Model:
    Nexus 6
    Twitter:
    https://twitter.com/Corey
    Sounds like the digitizer is bad. Replacing it is the only thing I know that will fix it

    Tapped from a Moto X
     
Search tags for this page

how do i fix my motorola milestone it just shows an m

,

the screen doesnot turn on android