My home WiFi is causing some apps and web pages to not work or load??

Discussion in 'Android General Discussions' started by mikehurt88, Jan 26, 2014.

  1. mikehurt88

    mikehurt88 New Member

    Joined:
    Jan 26, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    First of this is my first post here so sorry if its in the wrong area or if it has been talked about before but Im about to drive myself crazy trying to figure out what is wrong here

    Ok so heres my issue, I had an HTC Rezound and whenever I connected to my home wifi I could never use the facebook app, the facebook mobile web page, or basically any app that required me to use the internet like snapchat, youtube, pandora, etc and even some webpages will not load on my phone browser when connected... Now If I switched to regular 4g all of it would work and load with no issues. I only had these problems when I was connected with Wifi at my house. I decided to try someone elses wifi so I went over to a family members home and connected to their WiFi and everything worked fine with no issues at all so I dont know what the issue is here.

    I thought maybe it was my phone and I had an upgrade so I got the Samsung Galaxy S3 in hopes that it was possibly just the phone but even now with Galaxy S3 I still can't get any of those apps to hardly work unless I am just using regular 4g Data.

    Does anyone have any idea on how to fix this issue? It is very irritating having to disconnect from wifi everytime I need to use one of these apps and waste my data at home. I'm assuming since the apps and webpages load fine on someone elses network then it must have something to do with my router but I can't figure out what to do to fix it. Im using a Belkin Wireless router if that helps any.
     
  2. dvdcatalyst

    dvdcatalyst Guest

    Ratings:
    +0
  3. Ivin Thomas

    Ivin Thomas New Member

    Joined:
    Sep 26, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Galaxy S4
    I had this exact same issue for 6 months and suffered terribly. Apps like drippler and sites like wordpress wouldn't load no matter whatever I did. And believe me I did everything possible, till physically taking my router and thrashing it on the floor!! However from pure luck I found out from another online forum the solution and cracked it! Every sites and apps started loading as normal as it was meant to be. Here's what I did ( or atleast the forum asked me to do)

    1.Note down what the MTU value is currently set to on your router. (Most probably under your wireless settings in the router page)

    2.Change the MTU to 1468 and retest (reboot). Check the error site or app.

    3.If that fails to rectify the issue, change the MTU setting to 1400 and retest (reboot) again. Check the error site or app.

    4.If that fails to rectify the issue change the MTU back to the original value.


    I got my issue solved at the 3rd step and seriously hope it works for you guys too!
    Cheers.
    Peace out.
     
  4. xeene

    xeene Gold Member

    Joined:
    Jun 28, 2010
    Messages:
    3,065
    Likes Received:
    891
    Trophy Points:
    208
    Location:
    usa
    Ratings:
    +1,027
    Sounds like it would be easier to get a different router. They are dirt cheap nowadays unless you live on the moon.
     
  5. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,469
    Likes Received:
    7,049
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,391
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    The moon has free WiMax.

    For my money, Netgear is the router to have. Your opinions may vary, but I had 2 linksys in a row that had to be reset monthly or sooner for years before switching. I've never had luck with Belkin either, though I've only helped others with them, not owned one myself.
     
  6. bigmatt503

    bigmatt503 Active Member

    Joined:
    Jun 1, 2012
    Messages:
    203
    Likes Received:
    54
    Trophy Points:
    28
    Ratings:
    +54
    I have been using the netgear n900 for around 2 years without a single issue☺
    I can't say for sure but it was around 100 bucks at bestbuy.
     
Search tags for this page
amdroid wifi some sites not opening
,

android apps not working on wifi

,
facebook app not loading pictures
,
facebook wont load pictures on android
,
gs3 snapchat wont load on wifi
,
my browser wont load snapchat support
,
snapchat wont load on wifi
,
snapchat wont work with my wifi s5
,
some web pages not loading on android
,

why wont my phone load websites