My first port.....Miui 2.7.27 ported ontop Eclipse 1.2.5

Discussion in 'Droid 4 ROMS' started by Carboi81, Sep 2, 2012.

  1. Carboi81
    Offline

    Carboi81 New Member

    Joined:
    Jun 3, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    This is my first port, and I have nit had a lot of testing on it just yet. Matter of fact, I just got it running, and thought maybe some of the professionals could help me work out any of the major bugs that I have missed.
    I am an auto technician by trade, so I am sure that my programming skills are not nearly up to the par of many on here.
    I have been dying for a MIUI port for our device, and instead of waiting, I thought I would take on the test...maybe spark a fire under someone more skilled to show me how it is done.

    I would like to thank MIUIandroid.com and so many people over there as well as
    myfishbear for the most stable and complete ROM that I found (because I did try CM9 and AOKP to no avail)

    MiuiBeta2.7.27
    https://docs.google.com/open?id=0B0EVn95v06aSTkloQm9WYzF0R0E
  2. bizichild
    Offline

    bizichild New Member

    Joined:
    Sep 2, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    awesome! cant wait to try it

    Im going to buy a droid4 just so that I can use your miui port! Bad ass!
  3. Z4ck
    Offline

    Z4ck Developer Developer

    Joined:
    Jun 7, 2012
    Messages:
    201
    Likes Received:
    36
    Trophy Points:
    0
    Location:
    Flint,Michigan
    Good job
  4. VincentDHam
    Offline

    VincentDHam Member

    Joined:
    Sep 22, 2011
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hot boots every 15 seconds.
  5. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    Second that. Rom looks really promising though, I've been dying for some MIUI on my Droid 4. Keep up the amazing work, it's appreciated.

    Sent from my DROID4 using Tapatalk 2
  6. Cstryon
    Offline

    Cstryon Member

    Joined:
    Jan 25, 2011
    Messages:
    398
    Likes Received:
    2
    Trophy Points:
    18
    great job!

    Sent from my XT894 using Tapatalk 2
  7. kwyrt
    Offline

    kwyrt New Member

    Joined:
    Nov 9, 2011
    Messages:
    366
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Columbus, OH
    Awesome! Keep up the great work!

    Droid 4 - AOKP FLATLINER-KRUSH
  8. crockettc1
    Offline

    crockettc1 New Member

    Joined:
    May 21, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    When I flashed this I got some really scary looking Chinese (I think) screen with a big red symbol with a ton of writing. It stayed there for maybe ~10 minutes, and I reverted back to Eclipse as I thought something was wrong. Never actually got the ROM to boot up. Is this just the start up screen or did something go wrong?
  9. VincentDHam
    Offline

    VincentDHam Member

    Joined:
    Sep 22, 2011
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    i think thats the boot animation lol
  10. Montecarlo97z
    Offline

    Montecarlo97z New Member

    Joined:
    Sep 24, 2010
    Messages:
    363
    Likes Received:
    0
    Trophy Points:
    0
    please get this fully functioning... ive been waiting for miui ever since i got rid of my d2
  11. tips14
    Offline

    tips14 New Member

    Joined:
    Jul 18, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    this looks very promising. It reboots itself every minute or so. but when its working it is ridiculously smooth. i think wifi was working and I was getting reception and 3g. didnt get a chance to test out 4g though. keep up the great work man, I have faith in this one. I'd say try and get into contact with some other d4 devs and see if they can help work out the bugs cause I would absolutely love to run this as my daily driver. the only thing I might even consider running over miui is JB but thats in its alpha stages right now
  12. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    Trying to get the ball rolling here. I've got a working MIUI that doesn't hotboot every fifteen seconds. only problem is "com.android.phone" keeps force closing and I believe it's preventing me from getting service. Any suggestions?
  13. myfishbear
    Offline

    myfishbear Developer Developer

    Joined:
    Jan 30, 2011
    Messages:
    1,292
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    in the sea. sometimes on land as well
    pull the phone app from this guys rom and stick it in yours... just don use his system ui or framework.apk
  14. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    Didn't work... I'm using MIUI 2.8.31 because that's the only one I can find. I wonder if I trying 2.2.27 would fix things, but I can't find a download for it...
  15. Z4ck
    Offline

    Z4ck Developer Developer

    Joined:
    Jun 7, 2012
    Messages:
    201
    Likes Received:
    36
    Trophy Points:
    0
    Location:
    Flint,Michigan
    This is what i like to see around here helping each other

    Sent from my DROID4 using Xparent SkyBlue Tapatalk 2
  16. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    I give up, I can't figure it out...
    Last edited: Sep 5, 2012
  17. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    How did you fix the phone fc issue? Or did you even run into that?

    Sent from my DROID4 using Tapatalk 2
  18. Carboi81
    Offline

    Carboi81 New Member

    Joined:
    Jun 3, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    It was the phone.apk in my cm9 and AOKP roms that did that both to me. Eclispe was the first that I got that appeared semi stable. I even got it to place a call, but I am actually out of town for training, so not sure when I will be able to look at my framework to figure out all that is going on.....but I must admit, it is eating at me. I miss my Miui and its almost endless amounts of tweaks.
  19. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    I'm using Eclipse too, tried both 1.2.5b and 1.2.5c
    I'm using MIUI for spyder (Razr) 2.7.27 and 2.8.31

    Both those Miui versions have a libloc2.5OEM instead of liblocSDK_2.2, so that's confusing....

    I just can't get the phone/service to work.

    What are you using and how did you do it?
    Last edited: Sep 5, 2012
  20. GigaJake
    Offline

    GigaJake New Member

    Joined:
    Oct 8, 2011
    Messages:
    437
    Likes Received:
    17
    Trophy Points:
    0
    Nevermind! I've got it working!

    I'll try to clean a few things up before I post it. I have service and 3G, but not 4G. Someone is going to need to help me with that. LTE/CDMA isn't shown as an option, so it's not an easy fix I'm guessing...

    Also it seems like trying to use Wi-fi causes it to hotboot, or at least my campus network in particular. May have something to do with the security type.
    Last edited: Sep 5, 2012