My D2G has been a brick when I`ve flashed the SBF.

Discussion in 'Motorola Droid 2 Global' started by findingjulia, Jan 5, 2011.

  1. findingjulia

    findingjulia New Member

    Joined:
    Dec 16, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    HONG KONG
    Ratings:
    +0
    :frown:I flashed my d2g with rsd. and the sbf works well. but when I changed another battery, the phone cannot power on anymore. and try charger.no responsed. try the first one either. I try to use ubs-pc or the AC adapter, but the phone is still dead. I press the X and power button, but i can't access the system. even the bootloader mode.
    who can help me .thanks a lot !!!!
     
    #1 findingjulia, Jan 5, 2011
    Last edited: Jan 5, 2011
  2. mrmattch3w

    mrmattch3w Member

    Joined:
    Dec 28, 2010
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Santa Clarita, CA
    Ratings:
    +0
    how long did you let it sit when plugged into the wall? just plug it in and let it sit for an hour or so and try again. when the battery is less than 5% or if its completely dead it will not charge using USB
     
  3. Digital Cha0s

    Digital Cha0s Member

    Joined:
    Oct 22, 2010
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Still haveing this Issue

    did you use rsd lite 4.9? did you sit with the phone to wait for it to reboot, so you could make it reboot back into the bootloader so rsd would pass it? and did you charge the battery for at least an hour before tring to turn it back on? all these things would be helpfull in aiding your question
     
  4. fathcarter

    fathcarter Member

    Joined:
    Nov 22, 2010
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Also guys remeber to go into regular recovery if u didn't wipe the phone before. Mine did that even when I wiped before hand, it was bricked, then I went in recovery by holding x and wiped it again then it started right up.

    Sent from my DROID2 GLOBAL using DroidForums App